Announcement

Collapse
No announcement yet.

Custom avatars don't upload

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Custom avatars don't upload

    Originally people could use their own custom avatars, but a problem spontaneously developed. Now whenever anyone tries to link to their own, they get the error: The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again. I can't even change the avatars from the admin panel.

    Though the users can still choose from the default forum avatars. The admin panel for that gives a possible explanation: Using this feature required your web server and PHP to have permission to write files to disk. If they do not have the neccessary permissions, it will fail. But I haven't made any changes to the server or PHP, so I don't see where the problem came from.

    I had version 2.2.5 when the problem started. I upgraded to 2.2.7 in hopes that it would get fixed, but that hasn't made a difference. Can anyone offer any suggestions or a link that answers this question? (I searched but didn't find any similar threads).

    Hmm, this guy seems to have the same problem.
    Last edited by Lugnut; Sat 14 Sep '02, 5:36pm.

  • #2
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Phpinfo

      Comment


      • #4
        Your server is running in Safe Mode. You need to enable safe mode in the Admin CP and set the Safe Mode Temp Directory to a directory that has been chmod'd to 777.
        Last edited by Steve Machol; Sat 14 Sep '02, 6:11pm.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Changed it, but the error still appears.

          Comment


          • #6
            What temp directory are you using and are you sure it's permissions are set to 777?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              It's /tmp, so if it's pointing at the right directory, then yes it's chmod 777. I'll try other directories to see if it makes a difference.

              Comment


              • #8
                The /tmp directory is usually under the control of root. Unless you have root accfess you will not be able to change it's permissions.

                Make sure you use the full and exact path to whatever tmp directory you set up.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  *Big grin*

                  It works! It was just pointing at the wrong directory. (The proper entry was tmp not /tmp). Thank you sir!

                  Comment


                  • #10
                    vBulletin Community Forum > vBulletin 3 > vBulletin 3 Troubleshooting and Problems > Custom avatars don't upload
                    um aint read the post yet but surely its a vB2 prob?
                    www.xixora.com
                    Goldrush : A Soldier of Fortune Modification going for the GOLD!

                    Comment


                    • #11
                      Originally posted by XiXora
                      um aint read the post yet but surely its a vB2 prob?
                      Right you are!
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X