Announcement

Collapse
No announcement yet.

Problem with Upload Avatar and Attachment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Upload Avatar and Attachment

    Hi
    my board is: www.blizzyitalia.com/forum
    my phpinfo script is: www.blizzyitalia.com/admin/phpinfo.php

    I' don't understand why avatar and attachment upload doesn't run on my board.
    I've read that i've to set chmod 777 on httpdocs/tmp, but I'dont understand where're that directory.

    Thanks

  • #2
    The problem is that your PHP is not set to allow file uploads. To fix this, wither you or your host will need to add this line to php.ini:

    file_uploads = On
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I think that u wrong 'cause I've done script for file upload thata perfectly run on my server

      Comment


      • #4
        The phpinfo is pretty clear on this. Have you tried changing php.ini yet?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          No 'couse i've not access to php.ini I've to contact my host for this operation.
          But I'don't understand why my scripts can upload file in my server if that support is disable in php.ini?

          Comment


          • #6
            ?

            Comment


            • #7
              I'm not sure what you are waiting for. You need to modify php.ini as I suggested earlier.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                My question was: why can I upload file with my script (outside the vB) if u say that upload support is not enabled?

                Hi

                Comment


                • #9
                  Since I know nothing about the script you are talking about there's no possible way for me to know why this works.

                  If you want to fix the problem with vB, then you need to change the line in php.ini. If you don't change that line, then uploads won't work.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks.
                    Wherever my scripts run with copy() function.

                    Comment


                    • #11
                      As I said if you want to fix the problem add that line to php.ini. If not, there's nothing more I can do. It's up to you.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        If I have access to that file on my host, where would it be? I'm having the same problem when uploading avatars

                        Comment


                        • #13
                          Spart, please start your own thread rather than jumping on another one. And please post all the relevant info including the link to your phpinfo.php.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X