Announcement

Collapse
No announcement yet.

Admin CP login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin CP login

    Yesterday I installed a fresh copy of 2.2.7, everything is fine but I'm having a little problem on the Admin CP login page.

    When I visit the url the first time it returns me the following:

    PHP Code:
    Please Log in
    You are either not a valid administrator or have not logged in.

    <
    input type="hidden" name="PHPSESSID" value="7939f61e5248a26ebb 
    If I hit refresh, it loads correctly with the username and password fields, so I can login correctly.

    I deleted the cookie, emptied the cache, closed IE. Then I launched IE, typed in the Admin CP url and the error msg changed to:

    PHP Code:
    You are either not a valid administrator or have not logged in. <form action="../admin/index.php" method="pos 
    I repeated the tests several times, anyhow if I reload the page everything is fine, it does this just the first time I go to that url.

    The login page on the forum does not give me this kind of problem.

    It's not a serious problem but it's very very annoying.

    The only files that I modified are the ones related to the bugs found and fixed (by Chen and Scott).
    Last edited by Axel Foley; Wed 4 Sep '02, 6:57am.
    "Sometimes men stumble upon the truth and then hurry off as if nothing happened"
    - Winston Churchill -

  • #2
    Try reuploading admin/index.php. Make sure you upload in ASCII and overwrite the one on the server.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Yeah...

      When you wrote UPLOAD IN ASCII MODE I understood the problem.

      I had a problem last night with the ftp server. Every ftp client I use to upload transfers files in binary mode, even if I force ascii mode. If I do it via command-line it works fine using ascii mode.
      On other ftp servers I don't have any problems.

      So I followed your suggestion and I reuploaded index.php via command-line using ascii mode and the problem seems to be solved.

      Thanks for the help.

      P.S.: now I have to solve the ftp server transfer mode issue...could I have other problems with other scripts I transferred in binary mode?
      "Sometimes men stumble upon the truth and then hurry off as if nothing happened"
      - Winston Churchill -

      Comment


      • #4
        Nope..

        Sorry smachol but I tried again and the problem is still there.

        So I guess the problem is not index.php I guess. Could it be related to some other .php file I transferred in binary mode?

        PHP Code:
        Please Log in
        You are either not a valid administrator or have not logged in.

        <
        input type="hidden" name="PHPSESSID" value="5be9efe0f15d32447a 
        "Sometimes men stumble upon the truth and then hurry off as if nothing happened"
        - Winston Churchill -

        Comment


        • #5
          Yes it could be related to global.php and possibly others. Since you already know you had this problem, the safest thing to do would be to reuploadaqll the php files in ASCII.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Ok...

            Don't know how to solve this, I mean, it seems to be a problem with that specific ftp server, all the other ftp servers I use work just fine. But I can't understand why via cmd-line it works.

            As soon as I solve it I'll reupload all the files...

            Thanks again...
            "Sometimes men stumble upon the truth and then hurry off as if nothing happened"
            - Winston Churchill -

            Comment


            • #7
              I am getting this same error.. I cannot login after a fresh install of IIS, php, mySQL, and the v2.2.7 of the forum software on a Win2k Pro box.

              The install went through with no errors.

              Comment


              • #8
                It seems to the the terminal I am using to connect to the forums. I went to another terminal and logged in just fine.. It seems even tho I can use cookies on that bum terminal just fine since I am on here and such, but it seems to not want to work against my new forum.

                Ok further note, If you are trying to connect to the CP and the machine that it is installed on is part of your Intranet, and your client machine is windows based you may need to IE -> Tools -> Inet Options -> Privacy Tab and click on edit at the bottom, and add the domain that you are using your forums on.

                If you are using the machine name to connect to the forums, IE in some corporate environments (My case), you need to edit the host files on the client machines and map the forum server's ip to a internal domain name. In my case I just put

                192.31.230.25 temp.com

                and then went into IE -> Tools -> Inet Options -> Privacy Tab and click on edit at the bottom, and type temp.com and click allow.

                This fixes windows based IE problems on Intranets.

                Hope this helps some.
                Last edited by BetaMax; Thu 5 Sep '02, 1:19pm.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X