Announcement

Collapse
No announcement yet.

Atachments, avatars, argh!...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Use:

    images/avatars

    ...not:

    /images/avatars

    ...as the upload directory. Make sure you actually have an images/avatars directory and that it is chmod'd to 777.

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    replied
    I can do custom avatars from the user end, but I can't upload them in the Control Panel. I must have the directories wrong. Where should they go?

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    replied
    That worked for my attachments, but when I try to upload an avatar in the control panel I still get an error:

    Warning: Unable to create '..//images/avatars/avatar.gif': No such file or directory in /home/crapwagon.com/httpdocs/forums/admin/avatar.php on line 39

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    replied
    do I put it in the root directory, on the same level as images or cgi-bin...

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    You have open_basedir restrictions on your server. You need to create a 'tmp' subdirectory under your httpdocs directory, chmod it to 777, and then set the "Safe Mode Upload Directory" option in the control panel to point to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /usr/local/psa/home/vhosts/crapwagon.com/httpdocs:/tmp

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    replied
    Anyone out there?

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    replied
    www.crapwagon.com/forums/phpinfo.php

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Upload the phpinfo.php file from the 'extras directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.

    Leave a comment:

  • mclark2112
    Member

  • mclark2112
    started a topic Atachments, avatars, argh!...

    Atachments, avatars, argh!...

    OK I made my way through the install, and these boards are great! I am also a rookie webdeveloper. My problem is this, Everything seems to work fine except for the uploading of attachments and avatars. My users get a error that looks like this:

    Warning: open_basedir restriction in effect. File is in wrong directory in /home/crapwagon.com/httpdocs/forums/admin/functions.php on line 1719

    Warning: fopen("/tmp/phpvjSnaj", "rb") - Operation not permitted in /home/crapwagon.com/httpdocs/forums/admin/functions.php on line 1719

    Warning: Supplied argument is not a valid File-Handle resource in /home/crapwagon.com/httpdocs/forums/admin/functions.php on line 1720

    Warning: Supplied argument is not a valid File-Handle resource in /home/crapwagon.com/httpdocs/forums/admin/functions.php on line 1721

    I had my host run the script that I found in another post and I made the mods to the php files, still nothing.

    My question is this, whies do need on my server to directories I need to accomodate these files? What access do they need? Or am I completely thinking the wrong way. Are these files stored in directories or in the database?

    Thank You
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X