Announcement

Collapse
No announcement yet.

"Views" column has stopped counting!?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Views" column has stopped counting!?!

    Hey there ...

    recently my views column on the forum display page has stopped counting so all threads constantly read "0 views".

    does anyone have and idea why this might have happened? and what I might do to solve the problem?

    I am currently running v.2.2.6 and nothing has changed as far as the setup for over a year (with the exception being the upgrade to 2.2.6 (but I know that wasn't the problem))

    Thanks in advance

    Gordon

  • #2
    Upload repair.php from the extras folder and run it twice in your browser, see if that sorts the problem.

    If not then you may find that shutdown queries have been disabled, you will need to open /admin/functions.php and change

    PHP Code:
    $noshutdownfunc 0
    to

    PHP Code:
    $noshutdownfunc 1
    and upload the file again.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      ok ...

      so the repair script ....

      if I type repair.php?check=1&iterations=2&forum=<DBNAME>

      the page just reloads and sits there ... doesn't do anything.

      Changing the value of the variable in admin/functions.php to "1" ... well it is now working again ... views is counting like it should.

      My question is ... what went bad, that requires me to change that variable to "1"?

      basically ... what is going on in the code?

      Thanks

      Gordon

      Comment


      • #4
        your host has disabled shut down functions by the sound of it.
        Scott MacVicar

        My Blog | Twitter

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X