Announcement

Collapse
No announcement yet.

database problem..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • database problem..

    I just tried to change someones name at my board and I got this error below:

    "Database error in vBulletin Control Panel 2.2.6:

    Invalid SQL: SELECT userid
    FROM user
    WHERE username='zmouser'
    AND userid <>
    mysql error: You have an error in your SQL syntax near '' at line 4
    mysql error number: 1064"

    How do I fix this ?
    Last edited by Sykes; Sun 4 Aug '02, 8:46pm.

  • #2
    what version of PHP are you using ?

    make sure you've uploaded all of the vB 2.2.6's php files particularly /admin/user.php
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      Yeah what George said. It sounds like your running an older version of user.php. Make sure when you upload it you overwrite the one on the server.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I'm not sure what version of php venturesonline uses...I'll find out.

        I uploaded all 2.2.6 php files.

        Comment


        • #5
          Originally posted by smachol
          Yeah what George said. It sounds like your running an older version of user.php. Make sure when you upload it you overwrite the one on the server.
          alright thanks!

          Comment


          • #6
            yes overwriting the /admin/user.php fixed it. Must have been an older hack I put in not long ago.

            Thanks eva2000 and smachol!

            Comment


            • #7
              Originally posted by Sykes
              yes overwriting the /admin/user.php fixed it. Must have been an older hack I put in not long ago.

              Thanks eva2000 and smachol!
              no probs
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X