No announcement yet.

all topics locked at "private forum"

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    They are in the access table. You can view this in phpMyAdmin and see if there are any entires with userid equal to 0. If there are, then backup your databse first.

    Then backup the table with this query:

    CREATE TABLE accessbackup (
       userid int(10) unsigned DEFAULT '0' NOT NULL,
       forumid smallint(5) unsigned DEFAULT '0' NOT NULL,
       accessmask smallint(5) unsigned DEFAULT '0' NOT NULL
    INSERT INTO accessbackup SELECT userid, forumid, accessmask FROM access;
    ALTER TABLE accessbackup ADD UNIQUE (userid,forumid);
    Then delete the entires with this query:
    DELETE FROM access WHERE userid = 0;
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    • #17
      Steve, thanks for taking the time to type out the above code.

      This has taken an unexpected turn... in this thread... ... I found out that my problem isn't actually a "problem" ... the "private forum" setting is behaving as intended.

      So, I won't need to use your code. But, I'm sure that someone else will benefit from your above message. Thanks again for the continued support.


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.