Announcement

Collapse
No announcement yet.

'Too Many Connections' error... with a difference

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 'Too Many Connections' error... with a difference

    Hi guys,

    I have 2 vbulletins installed on my server (both licensed!). It's a dedicated server with 1gb RAM.

    Anyway, one runs fine with very very few problems, but the other gets the Link-ID == false error emailed to me every day around 30 times or so.

    Why would this happen with one vB but not the other? They're using the same MySQL server, although the sites themselves run off different IPs... (same instances of apache, sql, etc tho).

    Can anyone shed any light? It's getting right annoying!!

  • #2
    Link-ID == false error

    doesn't necessarily mean too many connections error

    it means mysql connection for that instance died or ended suddenly

    have you checked your mysql error log for ideas ?
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      This is the full error report:

      Code:
      Database error in vBulletin :
      
      Link-ID == false, connect failed
      mysql error: Too many connections
      
      mysql error number: 1040
      No, haven't check the sql error log Have to find it first!

      Comment


      • #4
        admin/config.php - try turning off persistant connections

        or increase the max # of mysql connections on your server.

        Comment


        • #5
          What's the advantage of turning Persistant Connections on?

          Comment


          • #6
            Persistent connections should only be used if overhead for a mysql connection is high, in most cases it should be left off.

            change

            $pconnect=1;

            to

            $pconnect=0;
            Scott MacVicar

            My Blog | Twitter

            Comment


            • #7
              I don't understand why any of that would affect only *one* of the forums though, and not the other?

              Comment


              • #8
                Originally posted by MarkB
                I don't understand why any of that would affect only *one* of the forums though, and not the other?
                probably your 1 vB forum is using more simultaneous connections and hitting the defined server limit for max_connections
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  The vB with all the errors gets max 14 people online, while the other gets around 140 at peak...

                  Comment


                  • #10
                    Is one forum using persistent connections and the other isnt?

                    It has to be something to do with your configuration.
                    Scott MacVicar

                    My Blog | Twitter

                    Comment


                    • #11
                      Both have pconnect set to 0...

                      Comment


                      • #12
                        very strange might want to upgrade php to 4.1.2 and mysql to 3.23.51 first

                        post the contents of your /etc/my.cnf file

                        make sure there is only one my.cnf file by typing as root user

                        locate my.cnf
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #13
                          my.cnf contents:

                          Code:
                          [mysql]
                          set-variable = max_connections=350
                          set-variable = key_buffer=16M
                          set-variable = myisam_sort_buffer_size=64M
                          set-variable = join_buffer=2M
                          set-variable = record_buffer=2M
                          set-variable = sort_buffer=3M
                          set-variable = table_cache=1024
                          set-variable = thread_cache_size=128
                          set-variable = wait_timeout=3600
                          set-variable = connect_timeout=10
                          
                          [safe_mysqld]
                          open-files-limit=8192
                          
                          [myisamchk]
                          set-variable = key_buffer=128M
                          set-variable = sort_buffer=128M
                          set-variable = read_buffer=16M
                          set-variable = write_buffer=16M
                          I'll work on upgrading PHP and MySQL as well, once I figure out how

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X