Announcement

Collapse
No announcement yet.

Installation issues- Why is this so hard?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by JGUNS
    don't I create the database simply by adding SQL on my host options?
    No that doesn't sound like it creates the database. You'll need to ask your host how to do this (since the procedure is different for each one.)
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      I am using valueweb. I did add the sql database in the control panel. The only other options that it gives are as follows:
      The MySQL server is mysql.yourdomain.xx.
      Your user name and password will be the same as your ValueWeb account.
      Otherwise, it only gives me the option to change the password or:
      Host Access Restrictions
      Host access restrictions is enabled by default, only hosts on the ValueWeb.net domain may access your database. This means that your web server and any scripts on that server may access your database but any other clients will be denied.

      If you would like to connect to your database from outside the ValueWeb domain then disable host access restrictions. This will allow any host on the Internet to attempt to connect to your database, ofcourse they will still have to know the correct username and password to log into it.

      It is suggested that you leave this feature enabled unless you are actually going to connect from outside the ValueWeb domain.

      I have left it alone. It also says that the server name is apus. Should I be putting that in the config file? Also, all I have is an IP address, so would the db name be mysql. IP addy?

      This is the error message that I get.



      Attempting to attach to database...


      Warning: Access denied for user: xxxxxxxxxxxxxxx(Using password: YES) in /xxxxxxxx/admin/db_mysql.php on line 38

      Warning: MySQL Connection Failed: Access denied for user: xxxxxxxxxxxvalueweb.net' (Using password: YES) in /xxxxxxxxxxxxadmin/db_mysql.php on line 38

      Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /xxxxxxxxxxxx/admin/db_mysql.php on line 47

      The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

      Comment


      • #18
        Originally posted by JGUNS
        IYour user name and password will be the same as your ValueWeb account.
        This is NOT the same thing as the dbusername and dbpassword. You have to set these up seperately, then manually attach that db user to the database.

        Attempting to attach to database...

        Warning: Access denied for user: xxxxxxxxxxxxxxx(Using password: YES) in /xxxxxxxx/admin/db_mysql.php on line 38

        Warning: MySQL Connection Failed: Access denied for user: xxxxxxxxxxxvalueweb.net' (Using password: YES) in /xxxxxxxxxxxxadmin/db_mysql.php on line 38
        That error is because one of these variables is wrong in config.php:

        $dbname
        $dbpassword
        $dbname

        ..or that user does not have permissions to access that db.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          Okay, someone please tell me if these answers are right:

          Database server type: MYSQL
          Database server hostname / IP address: ?? (I can just put my IP ADDY in?)
          Database username: My host username
          Database password: My host password
          Database name: Not sure about this one. The host says that mysql is running on server "apus" but I dont think that is the same. I see no where on their control panel that says what the Databast name is, do I set that?
          As for the allowed members question, I just put my username in correct?

          Also, I change the config.php file and it becomes config.php.new. I use this one to REPLACE the config.php file on the server correct? So, I get rid of it and copy the new one over?

          Comment


          • #20
            No, those values aren't right. You will need to contact your host and ask them for:

            $dbusername (the database user name, not the CPanel u/n))
            $dbpassword (the password for dbusername)
            $dbname (the name of your vB database)

            You will then need to copy config.php.ner to config.php then edit config.php with these values. Note that $servername is almost always set to 'localhost'.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21
              I believe its something to do with access rights to the MySQL database. I had the same problem when I first installed vB months ago. Now I'm trying another install and getting the same problem. The answer is somewhere in these forums! I **think** its write access to the database? I had to get my host to enable it though.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X