Announcement

Collapse
No announcement yet.

Error 2013 but server up for 6 days

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    You can turn off persistant connections in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0

    Leave a comment:


  • tucklis
    replied
    Originally posted by blazin
    I had the ISP set the wait_timeout value to 28800... so far no errors!!! its been about 10 hours.... never went that long without getting them so this is a good sign.

    Thanks guys for your help!
    I keep getting the error 2013 every now and then, maybe on average threee times per day. I emailed my host about the timeout value and they came back with:

    Our engineers have investigated the issue you have been experiencing and have suggested the following:
    The wait timeout on our share mysql servers is set to 300 seconds to avoid too many persitent inactive connections to the server, you may want to look into configuring the scripts to avoid persistent connections.

    Is this likely to be the problem? If so, will I get more errors as my userbase increases and will this be problematic?

    Thanks,
    Kerry

    Leave a comment:


  • php-resource.de
    replied
    i checked this setting with mysqlfront.
    maybe ther is a bug in this...

    Leave a comment:


  • George L
    replied
    Originally posted by php-resource.de
    now i have the same problems.
    my ISP have the wait_timeout value set to 8.

    i hope i can get him to change that!
    8 !

    you might as well not access mysql at that setting!

    Leave a comment:


  • php-resource.de
    replied
    now i have the same problems.
    my ISP have the wait_timeout value set to 8.

    i hope i can get him to change that!

    Leave a comment:


  • blazin
    replied
    Still, NO errors, I think i found my solution!

    Leave a comment:


  • George L
    replied
    Originally posted by blazin
    I had the ISP set the wait_timeout value to 28800... so far no errors!!! its been about 10 hours.... never went that long without getting them so this is a good sign.

    Thanks guys for your help!
    no probs

    Leave a comment:


  • blazin
    replied
    I had the ISP set the wait_timeout value to 28800... so far no errors!!! its been about 10 hours.... never went that long without getting them so this is a good sign.

    Thanks guys for your help!

    Leave a comment:


  • George L
    replied
    Originally posted by blazin
    I ran the mysqladmin command thru my shell access and this is what I get:

    Server version 3.23.40-log
    Protocol version 10
    Connection ###.###.## via TCP/IP
    TCP port 3306
    Uptime: 8 days 3 hours 42 min 13 sec

    Threads: 4 Questions: 14880474 Slow queries: 30 Opens: 848 Flush tables: 1 Open tables: 355 Queries per second avg: 21.121


    Also, my wait_timeout value is set at 90.
    wait_timeout = 90

    set it back to 28800 or 14400 or 7200 at least but not 90 seconds

    Leave a comment:


  • blazin
    replied
    I ran the mysqladmin command thru my shell access and this is what I get:

    Server version 3.23.40-log
    Protocol version 10
    Connection ###.###.## via TCP/IP
    TCP port 3306
    Uptime: 8 days 3 hours 42 min 13 sec

    Threads: 4 Questions: 14880474 Slow queries: 30 Opens: 848 Flush tables: 1 Open tables: 355 Queries per second avg: 21.121


    Also, my wait_timeout value is set at 90.

    Leave a comment:


  • George L
    replied
    Updated explanation at http://vbtechsupport.com/433/






    http://www.mysql.com/doc/G/o/Gone_away.html
    http://www.mysql.com/doc/C/o/Common_errors.html
    http://www.mysql.com/doc/S/e/Server_parameters.html
    http://www.mysql.com/doc/O/p/Option_files.html
    http://www.mysql.com/doc/S/H/SHOW_VARIABLES.html

    The most common reason for the MySQL server has gone away error

    1. Is that the server timed out and closed the connection. By default, the server closes the connection after 8 hours or 28800 seconds if nothing has happened. You can change the time limit by setting the wait_timeout variable when you start mysqld via your server's /etc/my.cnf as well.

    2. Another common reason to receive the MySQL server has gone away error is because you have issued a ``close'' on your MySQL connection and then tried to run a query on the closed connection. You can check that the MySQL hasn't died by executing mysqladmin version and examining the uptime.

    i.e. to check mysql uptime, in shell as root user type:

    mysqladmin -u root -p version

    3. You can also get these errors if you send a query to the server that is incorrect or too large. If mysqld gets a packet that is too large or out of order, it assumes that something has gone wrong with the client and closes the connection. If you need big queries (for example, if you are working with big BLOB columns), you can increase the query limit by starting mysqld with the -O max_allowed_packet=# option (default 1M) or via max_allowed_packet variable in your /etc/my.cnf file and restarting mysql after you edited your /etc/my.cnf file. The extra memory is allocated on demand, so mysqld will use more memory only when you issue a big query or when mysqld must return a big result row

    4. or simply your host restarted mysql.. i'd contact your web host
    Last edited by George L; Sat 9 Apr '11, 4:20am.

    Leave a comment:


  • Steve Machol
    replied
    Perhaps PHP is timing out on a large attachment transfer. Although usually will will get a more specific error about that.

    Leave a comment:


  • blazin
    replied
    ive been trying to find a pattern: it seems most of the errors have something to do with attachments, although i just got one that wasnt attachment related....and when i get a batch of errors, they all have the same session id.

    Leave a comment:


  • Steve Machol
    replied
    Honestly if you need to tell him that the MySQL server is going down then he's not really doing his job as a host. Just copy him every time you get these messages.

    Leave a comment:


  • blazin
    replied
    thanks for the quick replies. Is there anything I can suggest to him to maybe solve this problem? is there anything i can post from the server (variables, etc...) that would give any valuable info?

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X