Announcement

Collapse
No announcement yet.

Installation Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation Issue

    Hi I didn't see this in the links but this is the problem I am encountering. I am very early in the installation process
    -----
    Attempting to attach to database...


    Warning: Failed opening './db_MySQL.php' for inclusion (include_path='.:/php/includes:/usr/share/php') in /home/virtual/site94/fst/var/www/html/forums/admin/install.php on line 318

    Fatal error: Cannot instantiate non-existent class: db_sql_vb in /home/virtual/site94/fst/var/www/html/forums/admin/install.php on line 320
    ----

    Thanks for any suggestions you can provide!






    Any suggestions??

    Thanks!

  • #2
    Did you set up config.php with the proper info for your database?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Change
      MySQL
      back to
      mysql
      in config.php for $dbservertype.

      Comment


      • #4
        Attempting to attach to database...


        Thanks for the feedback. Something happened! The first two I imagine that I need to resolve with my hosting provider. The 3rd one may still be an issue I need your assistance in resolving?

        Thanks!
        --

        Warning: Access denied for user: '[email protected]' (Using password: YES) in /home/virtual/site94/fst/var/www/html/forums/admin/db_mysql.php on line 40

        Warning: MySQL Connection Failed: Access denied for user: '[email protected]' (Using password: YES) in /home/virtual/site94/fst/var/www/html/forums/admin/db_mysql.php on line 40

        Warning: Supplied argument is not a valid MySQL-Link resource in /home/virtual/site94/fst/var/www/html/forums/admin/db_mysql.php on line 47

        The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

        Comment


        • #5
          This latest error means one or more of the following variables in config.php is wrong:

          $dbusername
          $dbpassword
          $dbname

          When you fix this, then all errors should stop. If you aren't sure what these should be, then you'll need to contact your host.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I had some probs like yours with my new host, as smachol said, the answere is definatly in the config.php resolve these probs and you will be ok. When i made my mysql data base, it always used my host login name as well. in otherwords if i made a database called vbulletin, for the config.php i needed to put my """"""""hostusername_vbulletin"""""""""" as the database name.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X