Announcement

Collapse
No announcement yet.

[bug?] Unable to login into admin control panel.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [bug?] Unable to login into admin control panel.

    Hi,

    I've been attempting to upgrade my 227 boards with 228 in anticipation of 3.0. When my first attempt to upgrade failed I restored my web site from backup and made a copy of the site and data base making the required mods to bring my live site up as a test site for more attempts of upgrades. Each and every time I would walk through the upgrade and get no errors I would then apply my hacks and then attempt to log in as admin. It takes my user name and password displays "hold on a sec" and then goes back to the blank admin login screen.

    Now I assume you are going to blame this on my hacks so I repeated the process from scratch, making a copy of my live site and applied the upgraded 228 files and ran the upgrade with out error. Then before making any of my hack changes I attempted to log in ... Same results ...

    Now at this time I'm thinking that this may be due to an incompatibility between the new version of vbulletin and the version of phpportals that I'm running ... So this time I deleted my test web site and attempted a full new install of Vbulletin 228 . I get the same problem!

    This is a clean install and there are no hacks and I have also deleted all temp files and cookies

    Thanks for you help

    Kevin Barrett

  • #2
    Problem found with the help of Steve M

    Ok here is the problem, I was unable to log into the admin CP on a fresh install of VBulletin ( no hacks or other code added ). I had set up a new V-host to provide a test area and Called it portal_v3.trebia.com.... No problem I could get to the forum and login. I could not log into the Admin CP. Steve noticed that The server was not giving back a cookie ( Admin CP will not work with out Cookies i guess ) After looking at my server setup to ensure that I had not made a mistake, I changed the V-host name to portalv3.trebia.com and every thing worked.

    I have looked at The Apache Site and See no Cookie problem related to hostname containing an "_" so this may be a potential bug wiht VB. Any one in developmnet want to take a look ???

    I have attahced the output of phpinfo.php on my site. you will need to rename the file to remove the .txt extention

    Comment


    • #3
      vBulletin uses the setcookie in PHP so the problem could by PHP related, I'll give it a quick whirl just now to see the outcome.
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #4
        definately a PHP issue, i searched the bugs list on both the apache and php websites.

        I'll post some code to the PHP bugs list and hope for a response.

        http://bugs.php.net/20271
        Last edited by Scott MacVicar; Tue 5 Nov '02, 3:59pm.
        Scott MacVicar

        My Blog | Twitter

        Comment


        • #5
          Scott,

          Thanks for the follow-up ... I'm real interested in what the answer is ... in the end if it is not fixed we should let the community that it is an issue.

          Thanks again

          Kevin

          Comment


          • #6
            They've apparently replied to PPN's bug report:

            Sorry, but your problem does not imply a bug in PHP itself. For a
            list of more appropriate places to ask for help using PHP, please
            visit http://www.php.net/support.php as this bug system is not the
            appropriate forum for asking support questions.

            Thank you for your interest in PHP.

            Your nameserver is broken, see:
            http://www.rfc-editor.org/rfc/std/std13.txt

            Secion 3.5. Preferred name syntax, Page [10], shows allowed characters
            for hostnames. The underscore is not one of them.
            Underscores ("_") are not permitted in a hostname. Use a hyphen ("-") instead.

            Comment


            • #7
              OK so I messed up ...

              I guess The folks at RH and Apache are allowing ( to some extent ) illegal host names... According to the RFCs that is... Here is a quote from Mr. DNS the online authority on the subject of DNS issues.

              Just to be clear, underscore has *NEVER* been legal as a hostname character. Never. To this day it is still not legal. RFC 952 and RFC 1123 state the rules. Nevermind that it is legal in NetBIOS names. Nevermind that many Unix vendors tell you it is legal in their instructions for setting the hostname.

              Some people reject names with underscores in them at the DNS server because there's an option for it. That option exists because of some hoopla about root exploits in badly behaving applications that blindly pass the results of PTR lookups to other system calls. However, DNS servers were not designed to enforce hostname rules. Those rules should be enforced at the client, so the default setting on servers is to allow all characters through. That's the skinny on underscores.

              FYI, if you stick with the legal Internet *hostname* character set, you'll never run into problems.

              --
              Mr. DNS
              VeriSign Global Registry Services
              [email protected]
              http://www.acmebw.com/askmrdns/

              I guess I should have known better being a sys admin for over 20 years ... I guess I just got confused there ... Thanks for all of your help.


              Kevin Barrett

              Comment


              • #8
                Re: OK so I messed up ...

                Originally posted by recumbent615
                I guess I should have known better being a sys admin for over 20 years ... I guess I just got confused there ... Thanks for all of your help.
                Hey! Don't be so hard on yourself. It would have never occured to me! Of course, I think underscores are just plain ugly, so I never use them--legal or not. There's nothing like an attractive hyphen to get my day off to a good start.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X