Announcement

Collapse
No announcement yet.

Help me install MySQL problems!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help me install MySQL problems!

    I keep getting this error on step 3 of the installation:
    ----------------
    Attempting to attach to database...


    Warning: Can't connect to MySQL server on 'dmbcommunity.com' (111) in /home/bdweb3912k/dmbcommunity.com/public_html/forums/admin/db_mysql.php on line 38

    Warning: Supplied argument is not a valid MySQL-Link resource in /home/bdweb3912k/dmbcommunity.com/public_html/forums/admin/db_mysql.php on line 47

    The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

    ----------------------

    I don't know what the deal is. I know one thing though. The PATH shows here /home/bdweb3912k/dmbcommunity.com.........

    The path is supposed to be /home/www/bdweb3912k/dmbcommunity.com.......

    I don't know what to do!!!!! Please help!!!

  • #2
    what is line 47 in db_mysql.php? and you left the name "localhost" in config.php? or you change it to your host name? let me know. make sure you leave unchanged the server name part of your config.php.
    Floren Munteanu
    Axivo Inc.
    Axivo Searchlight - Turbocharge your web site

    Comment


    • #3
      Originally posted by nakkid
      what is line 47 in db_mysql.php? and you left the name "localhost" in config.php? or you change it to your host name? let me know. make sure you leave unchanged the server name part of your config.php.
      I'm not sure what you are asking.

      This is my config.php:

      // type of database running
      // (only mysql is supported at the moment)
      $dbservertype="mysql";

      // hostname or ip of server
      $servername="localhost";

      // username and password to log onto db server
      $dbusername="xxxxxxxx";
      $dbpassword="xxxxxxxx";

      // name of database
      $dbname="dmbcommunity";

      // technical email address - any error messages will be emailed here
      $technicalemail = "[email protected]";

      // use persistant connections to the database
      // 0 = don't use
      // 1 = use
      $usepconnect = "0";

      // which users are allowed to view the admin log
      // separate each userid with a comma
      $canviewadminlog = "1";

      // which users are allowed to prune the admin log
      // separate each userid with a comma
      $canpruneadminlog = "";

      -------------------------------------------------

      This is the error:

      Attempting to attach to database...


      Warning: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) in /home/bdweb3912k/dmbcommunity.com/public_html/forums/admin/db_mysql.php on line 40

      Warning: MySQL Connection Failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) in /home/bdweb3912k/dmbcommunity.com/public_html/forums/admin/db_mysql.php on line 40

      Warning: Supplied argument is not a valid MySQL-Link resource in /home/bdweb3912k/dmbcommunity.com/public_html/forums/admin/db_mysql.php on line 47

      The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

      ------------------------

      Line 40 looks like this:

      } else {
      if ($usepconnect==1) {
      $this->link_id=mysql_pconnect($this->server,$this->user,$this->password);
      } else {
      $this->link_id=mysql_connect($this->server,$this->user,$this->password);
      }

      ----------------------

      Line 47 looks like this:

      if ($this->database!="") {
      if(!mysql_select_db($this->database, $this->link_id)) {
      $this->halt("cannot use database ".$this->database);

      ----------------------

      I really don't know what to do anymore. If someone would like to try to help me get beyond this, you may get in touch with me via email or AIM me "Pabs815" or Yahoo IM "tap4636" ICQ is "42571584".

      Thanks.

      Comment


      • #4
        Contact your web host and ask what is the correct mysql server name. If the database is on the same server as your files then $servername should be localhost.. If it is and you're still getting that error it means that mysql cannot find the mysql.sock file. Contact your host to fix the problem.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by smachol
          Contact your web host and ask what is the correct mysql server name. If the database is on the same server as your files then $servername should be localhost.. If it is and you're still getting that error it means that mysql cannot find the mysql.sock file. Contact your host to fix the problem.
          They gave me a PATH to the mysql.sock file. Should I put that PATH in the $servername in the config.php???

          Comment


          • #6
            No, it's up to them to properly configure MySQL to use the correct path.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              So do you think that it being the wrong path is what is making the connection fail?

              What should I say to them? Because I have a feeling they want me to do something with this path, as in implement it somehow in the connection.

              Comment


              • #8
                Tell them the error message you're getting:

                Warning: Can't connect to local MySQL server through socket '/tmp/mysql.sock'
                A good host will see that this is a server issue and try to find and fix the problem.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  They basically told me to go to hell.

                  So I guess I better find myself a new host.

                  Wanna know what they said?

                  They said that it must a problem with the way vBulletin's script is!!!!

                  HAHAHAA!

                  vBulletin is on what? 500,000 sites???

                  They were giving my a path to the MySQL path and telling me to put it into the config.php.

                  What a bunch of jerks. Damn I'm pissed.

                  Comment


                  • #10
                    Is it possible that the PATH they gave me for the MySQL server can be implemented somehow in the db_mysql.php????

                    I'm reaching for all possibilities.

                    Comment


                    • #11
                      They basically told me to go to hell.
                      Classy host you got there.

                      No, you don't want to touch db_mysql.php. Let's try something first. Create a new file called phpinfo.php with this content:

                      PHP Code:
                      <?php
                      phpinfo
                      ();
                      ?>
                      Then upload it to your webspace and post the URL here.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Classy host? Understatement of the year.

                        Here is the URL:

                        http://www.dmbcommunity.com/forums/phpinfo.php

                        Comment


                        • #13
                          It looks like the socket is at /tmp/mysql.sock which is what the error message says it's trying to connect to. Is that where they told you it was?
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by smachol
                            It looks like the socket is at /tmp/mysql.sock which is what the error message says it's trying to connect to. Is that where they told you it was?
                            This is the path they told me it was.

                            /home/bdweb3912k/dmbcommunity.com/.database/mysql/mysql.sock

                            Comment


                            • #15
                              Originally posted by Pabs


                              This is the path they told me it was.

                              /home/bdweb3912k/dmbcommunity.com/.database/mysql/mysql.sock
                              That doesn't make any sense. The path is clearly /tmp/mysql.sock as indicated by the phpinfo.php file.

                              What kind of a host is this?
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X