Announcement

Collapse
No announcement yet.

Register Problem with '

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Register Problem with '

    Some users want a ' in their nicks, and for an example the user register A'joe then i get this error..

    "Invalid SQL: SELECT COUNT(title) AS starts FROM thread WHERE
    postusername='A'joe' AND open!='10'
    mysql error: You have an error in your SQL syntax near 'j' AND open!='10'' at
    line 1

    mysql error number: 1064"

    This is when i want to go to his profile ect..

    how to fix this ?
    You already made up your mind!

  • #2
    well the problem is that the code should be

    Code:
    SELECT COUNT(title) AS starts FROM thread WHERE 
    postusername='".addslashes(A'joe)."' AND open!='10'
    can you post the entire error message, as that also identifies the file as well as vBulletin version you are running.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      Iam running 2.2.4.. and the that was the whole error message.
      You already made up your mind!

      Comment


      • #4
        If you upgrade to 2.2.5 it's *possible* the error will go away

        Comment


        • #5
          This is caused by you hacking your forum. Please visit www.vbulletin.org for assistance.

          Comment


          • #6
            Freddie > okay.
            Cary > I dont see the meaning with upgrade when i have to install all the hack's again, and confige my .php files.
            You already made up your mind!

            Comment


            • #7
              The reason to upgrade is to fix a security hole in the version you are running. As long as you run 2.2.4, your forums are at risk. It's up to you to decide if accepting that risk is more acceptable than spending the time to upgrade and reinstall your hacks. Personally I'd choose security over convenience, but that's just me.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                smachol, Sure you have right there, but i decide to wait to vB3 to come.. then i can upgrade.. Its about 1-2 Hours work to upgrade my forum..
                You already made up your mind!

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X