Announcement

Collapse
No announcement yet.

Help: Avatar Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help: Avatar Problem

    I am having a serious problem using avatars:

    when I try to upload one, it says "Thankyou for updating your options", but no avatar appears under my name when I post. When I attempt to load one from a location on the net, it always says "This is not a valid gif or jpg file", but it is. Help!?

  • #2
    We need a little more info. Create a file called phpinfo.php with the following content:

    PHP Code:
    <?php
    phpinfo
    ();
    ?>
    Then upload it to you forums directory and post the URL here.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I already have one:

      http://www.aviationforum.org/forums/phpinfo.php

      Comment


      • #4
        You host is running an insecure version of PHP and it appears that rather than upgrade PHP to the lastest version, they have disabled PHP file uploads instead. Contact your host and ask them to upgrade PHP and restore the upload function.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          partially correct php 4.06 is insecure and should be upgraded to php 4.1.2

          however you phpinfo indicates you have no value definied for file_uploads.. i believe it defaults to on

          i see php has been compiled with safe_mode enabled by default and safe_mode is enabled in php 4.06

          do you have safe_mode set to yes in vB admin panel -> vbulletin options -> upload ?
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            Originally posted by eva2000
            partially correct php 4.06 is insecure and should be upgraded to php 4.1.2

            however you phpinfo indicates you have no value definied for file_uploads.. i believe it defaults to on

            i see php has been compiled with safe_mode enabled by default and safe_mode is enabled in php 4.06

            do you have safe_mode set to yes in vB admin panel -> vbulletin options -> upload ?
            It is set to "no".

            Comment


            • #7
              Set it to 'yes' and then specify a 'Safe Mode Temp Directory' that has been chmod'd to 777.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                OK.

                Comment


                • #9
                  Standby...

                  Comment


                  • #10
                    Doesn't look like it did anything...

                    I'll just ask my host about upgrading to 4.1.2

                    Comment


                    • #11
                      Yeah, that may be the best idea. Even though eva2000 said the default for file_uploads should be on, the fact is that when it is set to 'on' that value in phpinfo.php should show as '1'.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        K.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X