Announcement

Collapse
No announcement yet.

mysql error number: 1044

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql error number: 1044

    this problem has arisen today, the forums have been running perfectly ok for the last 8 months, whenever me or a user tries to connect to the forums www.rtcw.co.uk/forums an error message is displayed as follows,

    Database error in vBulletin 2.2.1:

    Invalid SQL: INSERT INTO session (sessionhash,userid,host,useragent,lastactivity,location) VALUES ('a528d6aa9d4706bc908abe2550d86712','1','195.152.234.205','Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)','1019160734','/')
    mysql error: Access denied for user: '[email protected]' to database 'db30111544'

    mysql error number: 1044

    Date: Thursday 18th of April 2002 10:12:14 PM
    Script: http://www.rtcw.co.uk/forums/
    Referer:

    ive been through several threads and it looks like its either down to incorrect config file or a hosting problem,

    the forums have been unchanged for a good few months, but in desperation i have reloaded the config file and triple checked the username /password etc,

    im able to SSH to the server and back up the databases, and ftp is working ok, using the same username and passwords

    and to my suprise phpadmin still works and im able to browse the various mysql tables,

    and the homepage www.rtcw.co.uk uses several php includes which pulls data from the forums and this still displays data from the forums

    im stumped

  • #2
    site has been down 2 days now , my hosts are saying that they cant currently see a problem with my account , ive rechecked my config about 20 times anyone help ?

    Comment


    • #3
      Re: mysql error number: 1044

      Originally posted by xcal
      mysql error: Access denied for user: '[email protected]' to database 'db30111544'
      .
      .
      .
      ive been through several threads and it looks like its either down to incorrect config file or a hosting problem,
      You're right. For whatever reason the server is no longer allowing your username access to this database. You need to contact your host and ask why.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        your mysql server name is infong75.kundenserver.de and not localhost in your config.php ?
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          the mysql server name in my config .php is

          Database configuration
          Datebase name db30111544
          Host db02.oneandone.co.uk
          Port 3306 (Standard port)
          User name u7476952


          this has always been in the config.php, forums have been working for 8 months no hassle,

          the server above is whats listed in my web control panel as the mysql database to use,

          i use pluhnews for my news on the main page , this results in 1 of the online users being the infong75.kundenserver.de ip address showing up in the online users section (when the forums working) so it must resolve to this

          the thing thats bugging me is that forum data is still being extracted onto the home page

          www.rtcw.co.uk but the forums dont work :/
          Last edited by xcal; Fri 19 Apr '02, 9:15pm.

          Comment


          • #6
            if you changed your mysql server to localhost does it work ?
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment


            • #7
              im stuck at work atm, i will try in approx 2 hours and post back the results,

              Comment


              • #8
                Originally posted by xcal
                im stuck at work atm, i will try in approx 2 hours and post back the results,
                ah okay.... let us know how it goes
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  when i change the server name to localhost iget this error,

                  Warning: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111) in /homepages/31/d25193582/htdocs/forums/admin/db_mysql.php on line 40

                  Warning: MySQL Connection Failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111) in /homepages/31/d25193582/htdocs/forums/admin/db_mysql.php on line 40

                  Comment


                  • #10
                    looks like you need to contact your web host and ask what are the correct mysql server name...

                    if the database is on the same server as your files then it should be localhost... and if it is.. and youhave that error, then you web host needs to tell mysql the current path to mysql.sock file

                    let us know what your web host says and how it goes
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #11
                      ok major update, since my hosts have checked out the mysql access they reported back to me that there wasnt a problem, the problem has been ongoing for a couple of days so i decided to take some action,

                      i took a copy of the database through SSH and saved it,

                      i then re-installed from scratch v2.21 deleting every single table and starting from fresh, using the same login details as posted above and the forum install without a problem,

                      so then i restored all my tables from the backup 150mb, and tried testing the forum, while i was still restoring the backup (it had to got about table :word in ,in php admin ) i refreshed the forums home page and the forum came back to life, i even managed to read some private messages i had recevived before the forums went belly up.

                      unfortunately after all the tables had been restored i refreshed the forums again and exactly the same error appeared as originally posted - mysql 1044 access denied,

                      so now ive reached the situation where i know there isnt a problem with my settings in config.php because i have left a test forum up and running

                      www.rtcw.co.uk/forums

                      so what can i do to resolve the problem - i have 1 backup of 150mb which has all the current posts /users information in it which when i re-install from screws up the forum again,

                      is there a particluar problem i could edit through phpadmin to resolve this? or am i faced with restoring to an earlier backup - taken in january whereby i lose 1000 new mebers details and everyones posts?

                      Comment


                      • #12
                        Did you previously install any hacks which added or modified tables in the database? If they added tables, try removing them with phpMyAdmin. Otherwise try uploading repair.php (it's in the 'extras' folder of the zip file) to your admin directory and run it from your browser. Turn off your forums first though.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          ok ive wiped my database and reloaded the latest version of my back up, i did have vbstats installed which added some extra tables , so thru phpadmin ive deleted these tables, so im left with all the standard files,

                          i tried uploading repair to the admin area but as soon as a try run in it gives a 1044 mysql error,

                          ive tried using the repair function in phpadmin also and this gives the same error,

                          and just to make matters worse i have tried uploading my back up copy from january, this populated all the tables ok but when i tried to access the forum no pages appeared, and tbh i dont even know what copy of vb this data was taken from and whether it would work with 2.2.1 ,

                          im really really desperate now

                          the only thing i can think to do if back up certain tables from this copy (the latest one) and re-install 2.2.1 then swop the empty tables over using SSH access, but i dont know if this would work?

                          and how i would go about backing up a certain table using SSH ?

                          i could seriously do with someone who is better technically with mysql than myself to help me

                          Comment


                          • #14
                            If you're getting the exact same error with repair.php then this is further indication that the problem is with the server. I don't know what more we can do. You need to discuss this with your host.

                            mysql error: Access denied for user: '[email protected]' to database 'db30111544'
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X