Announcement

Collapse
No announcement yet.

280 MB backup.... won´t work...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 280 MB backup.... won´t work...

    Hi,

    i got a prob after creating the backup and upload it to my new server (had to... no telnet or ssh on the old server...) i connectet to my new server via SSH and entered

    mysql -h ***********-p -D *********** < backup/vbulletin.sql

    that all works pretty fine.. as long as a file isn´t bigger than 10 MB... but now it is so what can i do ? Or do anyone have something that split my file into 30 small ones... on the server would be the best as it needs 5 hours to upload that backup.... and don´t want to let my user wait sooo long again..

  • #2
    hmpf btw i searched the forum and i can´t change the mysql file as i share it with more user´s... so split the files seems to be the only possibility...

    Comment


    • #3
      The command should be

      mysql -u mysqlusername -p databasename < /path/to/backup.sql

      sounds like your host server doesn't have mysql optimised and configured correctly, 280mb shouldn't still be importable unless the server's hardware specs is very low or the server has too many shared sites on it
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        uhm yeah thats no help anyway ^^ so k what i did.. or what i´m doing is :

        split -C 3m vbulletin.sql test.sql

        on the unix system (via ssh) to split that big file into 3 Megabyte sized files (-C says that he should not cut lines and use file size not greater than 3 mb (you can say 3 mb size and cut line or you can say the number of lines instead)

        after that i got a lot of iles all executeable:

        mysql -h hostipof server -ppassword -D databasename < test.sqlaa

        mysql -h hostipof server -ppassword -D databasename < test.sqlab
        .....

        line by line not the best way but i guess it works for now..

        (filesize should be lower ^^)

        Comment


        • #5
          Maybe this page will help for the future.

          I just ran into the same problem with my 1.2GB SQL dump file. IT wouldnt' work...no matter what I changed in the my.cnf

          So...I plan on backing up each table seperately somehow now using "BACKUP TABLE"

          Maybe this page will help too: http://www.mysql.com/doc/B/a/Backup.html
          PaintballCity.com
          VB Board of the Month: October

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X