Announcement

Collapse
No announcement yet.

Problem with Avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Ok thanks.
    Well i know that the forum recently moved to a dedicated server.
    I looked for this "tmp" directory but couldnt find it anywhere.
    Do you know where it should be? thanks

    Comment


    • #17
      It shoud be /tmp, exactly as it shows in your phpinfo file. If this directory doesn't exist, then that could certainly be part of the problem.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        ok i will create a "tmp" directory in the root and chmodd it to 77 and let you know what happens

        Comment


        • #19
          no luck, all that happens is whether i try to upload it or enter the url to a file already uploaded, i just get the error that its not a valid GIF/JPG file.

          i made sure that the "use custom avatar" radio button was checked bothy times :/

          Comment


          • #20
            if you're using plesk then try this, that might be the problem.

            Comment


            • #21
              hey, whats plesk and how can i tell whether its installed? thanks hehe

              Comment


              • #22
                Ahhh, I just looked at your phpinfo again and noticed that your are running in Safe Mode. You'll need to go into your Admin CP/vBulletin Options/Upload Options and turn this feature on. You'll also need to include the full and exact path to the tmp directory that is chmod'd to 777.

                One word of caution however. As long as you are running PHP 4.0.6, you are taking a big security risk by allowing file uploads. If I were you, I would not allow uploads until I upgraded to 4.1.2.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #23
                  Ahh ok, I will have to get dave (server owner) to upgrade, but ill try to fix the avatar prob at least so i know i can

                  Comment


                  • #24
                    By the way, it does look like you are running Plesk. From your phpinfo:


                    HOSTNAME: plesk.rackshack.net
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #25
                      ok i did that, and i changed it to work in safe mode and i set "Allow Image Size Checking Failure?" to yes

                      and when i tried to upload i got the following error:
                      WARNING: SAFE MODE restriction in effect. The script whose uid is 10002 is not allowed to access /tmp/50x50.gif owned by uid 0 in usr/local/psa/home/vhosts/tutorialforums.com/httpdocs/member.php on line 1015

                      strange....

                      Comment


                      • #26
                        Did you look at the Plesk link that Sn2 posted? As many people will attest to - Plesk is Evil!
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #27
                          yes, but there is nothing i can do about that i will have to get the person who hosts it to do it.
                          I still have probs enetering a URL to a custom avatar, hehe it comes up as a red X when the image exists.

                          Comment


                          • #28
                            hey this is Dave, the guy Robouk was referring to who owns the server... yep running Plesk 2.0, just upgraded to PHP 4.1.2 this evening.... mysql version is 3.23.36 (trying to see how to upgrade that without screwing up plesk haha).... we're using vB 2.2.4

                            The /tmp directory he was referring to is in the root of the server, and is set to 777, though the files inside seem to have minimal permissions (should they be 777 too?). Or, should I make a new tmp directory inside the virtual server's httpdocs folder and set a full unix path to that?

                            Can you take another look at http://www.tutorialforums.com/phpinfo.php again and see if anything new and helpful is in there since I've upgraded PHP and whatnot? Are there any other upgrades I absolutely need? (I'm used to having been pampered for the last 2 years with a RackSpace managed server, but it got too expensive so we're trying rackshack).

                            Thanks!
                            -- David
                            + TutorialForums.com
                            + Photoshop-Tips.com

                            Comment


                            • #29
                              Here is a screenshot of me trying to attach a GIF file in a post....

                              http://www.tutorialforums.com/vb-attach-problem.gif
                              -- David
                              + TutorialForums.com
                              + Photoshop-Tips.com

                              Comment


                              • #30
                                Have you looked at the link Sn2 posted earlier in this thread?

                                http://vbulletin.com/forum/showthrea...threadid=37766

                                If that doesn't work, do a search for 'plesk problems'. Many people have had problems with Plesk and have posted workarounds.
                                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                                Steve Machol Photography


                                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X