Announcement

Collapse
No announcement yet.

BBcode problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BBcode problem

    Help!
    I was messing with my BBcodes, and tried to add a new one. The new code did not work, and now I get a "Warning: Unknown modifier 'n' in /home/mysite/public_html/admin/functions.php on line 723" error message. Anyone have any ideas on how to fix this?

    Thanks
    Jbear6
    Thanks
    Jbear62000


    vB ver 2.0.3 - License info is located in my profile :)

  • #2
    yep
    what's on line 723?
    try uploading original functions.php to your admin folder.
    You're my Prince of Peace
    And I will live my life for You

    Comment


    • #3
      What does your BBCode look like?
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        I have had the "inwindow" bbcode (working) like this :
        [ inwindow=300 ]www.yahoo.com[ /inwindow] is replaced with (<div align=center><iframe name="cwindow" style="border:0" width=1000 height=300 src="http://www.yahoo.com"></iframe>)

        I tried to add another one:
        [ inwindow2=300 ]www.yahoo.com[ /inwindow2 ] is replaced with ()
        [edit] [remove]

        and then I clicked on "Save" again, and got this:
        is replaced with () (don't ask me why I clicked on save)

        I added the spaces before and after the brackets to post the code here.

        The first error message a received was from the bbcode.php page. I saved the existing bbcode.php, and uploaded a fresh one from the 2.0.3 installation zip file. That is when I received the current error from the functions page. I saved the existing functions.php, and uploaded a fresh one from the zip file. I still received the function.php error, so I uploaded the "original" functions, and bbcode files that I messed up.

        I don't know what is on line 723, I tried counting the lines, but the file ended before I got to 723 (I counted the lines in notepad).

        Thanks
        Jbear62000

        UPDATE: I removed both "new" bbcodes, and everything seems to be working fine. Thanks to Luke and to nuno!
        Thanks
        Jbear62000


        vB ver 2.0.3 - License info is located in my profile :)

        Comment


        • #5
          If you don't have too many hacks installed, then you should definitely upgrade to 2.2.4 then, that would probably fix the problem since functions.php tends to be patched up in every new version.
          --filburt1, vBulletin.org/vBulletinTemplates.com moderator
          Web Design Forums.net: vB Board of the Month
          vBulletin Mail System (vBMS): webmail for your forum users

          Comment


          • #6
            Thanks filburt1

            If there are no security issues with 2.0.3, I am happy with that version as it is. We have over 4500 members, and they hate change
            Thanks
            Jbear62000


            vB ver 2.0.3 - License info is located in my profile :)

            Comment


            • #7
              Originally posted by jbear62000


              I don't know what is on line 723, I tried counting the lines, but the file ended before I got to 723 (I counted the lines in notepad).
              bear, in notepad hit Ctrl+G
              You're my Prince of Peace
              And I will live my life for You

              Comment


              • #8
                Re: Thanks filburt1

                Originally posted by jbear62000
                If there are no security issues with 2.0.3, I am happy with that version as it is. We have over 4500 members, and they hate change
                Your templates wouldn't change enough for them to notice. Here's the list of changes: http://www.vbulletin.com/members/changelog.php
                --filburt1, vBulletin.org/vBulletinTemplates.com moderator
                Web Design Forums.net: vB Board of the Month
                vBulletin Mail System (vBMS): webmail for your forum users

                Comment


                • #9
                  Re: Thanks filburt1

                  Originally posted by jbear62000
                  If there are no security issues with 2.0.3, I am happy with that version as it is. We have over 4500 members, and they hate change
                  There is a big security whole patch in versions 2.2.3+... I'd suggest upgrading.

                  Comment


                  • #10
                    I think Ian means there are security wholes in all versions prior to 2.2.4. There's quite a large on in 2.0.3. Your forums are at significant risk until you upgrade to the latest version.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      To get your forum working correctly again you will have to delete the corrupt inwindow2 BBCode. It is erroring out because of this corruption.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API - Full / Mobile
                      Vote for your favorite feature requests and the bugs you want to see fixed.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X