Announcement

Collapse
No announcement yet.

Email Verification LinkNot working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Verification LinkNot working

    Lots of users (new ones) are complaining that the email verification link in the email that is sent out never works. I tested it myself on Yahoo! and on my personal email accounts, and I get the same results:

    We could not activate your account because this web address is not valid. Make sure that you have the entire address from the email, and that your email client has not split the address over several lines.
    Any fix for this?

    http://www.amdforums.com/

    PHP 4.0.6

    MySql Latest

    Apache latest

    Red Hat 7.2

    Error message abovee

    Not edited any files

    Forum just upgraded to 2.2.4 but this problem also happened on 2.0.3
    Last edited by Vigile; Thu 21st Mar '02, 10:56am.

  • #2
    The registration link has the directory /vb/ in it, but there's no such directory on your server. Make sure you have the correct URL in your =Admin CP.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      No, www.amdmb.com/vb/ and www.amdforums.com/ are the same directory with Apache.

      So, go to www.amdmb.com/vb/ and register -- the same thing happens.

      Comment


      • #4
        The vb directory did not work when I tested it before. regardless it sounds like your done some modifications to htaccess or something else that may be icausing this problem. Not knowing what exactly you've done, I can't even begin to offer a solution.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          How does htaccess affect the address:

          To complete your registration, click on the link below:
          http://www.amdmb.com/vb/register.php...954&i=36122230

          That is what is not working.

          Comment


          • #6
            It's just a guess on my part - that's all. The fact that you have it set up so that www.amdmb.com/vb/ and www.amdforums.com/ point to the same directory may be the cause of the problem. As I said, without knowing exactly what you've done I can't even begin to guess.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Tired of hearing from me smachol?

              I am still trying to figure this one out:

              The link: http://www.amdmb.com/vb/register.php...340&i=74630813

              doesn't work, but then using the form and using the same number with that account works fine.

              http://www.amdmb.com/vb/ is the forum. Me and my sys admin decided the htaccess should affect anything on it at all.

              If anyone can help, I would appreciate it!

              Comment


              • #8
                Well I'm out of ideas. Good luck!
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I saw this happen on another forum here that I joinded today. If it's any help they were using the latest version of VB.

                  I don't use the email verification on my forums so I can't check it.

                  Mike

                  Comment


                  • #10
                    Anyone besides smachol wanna take a stab at this?

                    Please?

                    Comment


                    • #11
                      Having your forums accessible through two different URLs is always a bad idea... especially if the two urls aren't even of the same domain. I'm afraid you are asking for problems doing this...

                      Comment


                      • #12
                        I dont understand how that would affect anything, guys.

                        In my options, my URL is this: http://www.amdmb.com/vb

                        So that should work.... right?

                        Why isn't email verification working then? It's a just a URL from an email! The link works, it finds the page and everything, it just says there a problem. It's not like I am getting a 404 error or anything.

                        Comment


                        • #13
                          I'd trust Kier's judgement on this one!

                          One thing I didn't ask - what do you have as your Cookie Domain setting in the Admin CP?
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Cookie domain is blank.

                            Okay guys. I appreciate the comments but no one has really even suggested anything to try... ?

                            If you can describe out the registration URL page works besides taking the variables in the URL and checking them, then verfiying the users account... please do.

                            Comment


                            • #15
                              Also, in Apache, here is my line that makes Amdforums.com work on amdmb.com/vb

                              <VirtualHost 63.106.2.18>
                              DocumentRoot /home/amdmb/www/vb
                              ServerName www.amdforums.com
                              ServerAlias amdforums.com *.amdforums.com
                              </VirtualHost>

                              Can't get any simpler than that. Thus, going to www.amdmb.com/vb/anything is the same as www.amdforums.com/anything

                              I have been doing this kind of hostings for years and don't see how this can possibly affect PHP or vB's ability to verify a URL using URL variables.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X