No announcement yet.

regarding the "no forum specified error"

  • Filter
  • Time
  • Show
Clear All
new posts

  • regarding the "no forum specified error"

    If you are just having this problem when trying to post a new thread/reply, please see the following thread:

    There was a security release from that had to do with a vulnerability in the upload routine native to php. They have issued a patch for it, and have advised everyone to turn uploads off for the time being. What it looks like happened is that several hosting companies possibly turned off register_globals also, even though it wasn't mentioned as a vulnerability in the alert.

    the devs are banging their heads together to try to come up with a solution, so all we can ask is that you contact your hosts to see what they did to register_globals in php and try to get them to turn it back on, and be patient as we try to find a workaround for those who won't turn it back on.

    It's off in the newer releases by default, and some of the companies who recompiled may not be aware of this.

    [edit: Changed setting name, it's register_globals, not track_vars]
    Last edited by Mike Sullivan; Mon 4 Mar '02, 7:52pm.

  • #2
    im not sure about all persons but alot of people on my board are avoiding the error by changing the option in UserCP to browse the board using cookies, not sure if this is just a coincidence or not yet.
    Microsoft Beta Team


    • #3
      Thank you to the mods and the developers of VB for taking this issue seriously. It appears this is effecting many members by the multiple threads on the same issue.

      One thing mentioned is that the webhost may have possibly turned off track_vars. I talked with Martin earlier....he went into my cp and told me that my track_vars are that might not be the problem. Im talking to my host tommorow to see exactly what they did yesterday and I will report back.

      thanks guys.


      • #4
        The setting you need to check isn't track_vars, as this is always on for newer versions of PHP, it's "register_globals". For PHP versions 4.1 and above, this setting defaults to "off", while it defaulted to "on" in prior versions. If you or your host upgrades to the newest PHP 4.1.2, you need to make sure register_globals is set to "on" in the php.ini file for vBulletin (and many other PHP applications) to work properly.


        • #5
          ok thanks I'll let them know.


          • #6
            If you're running Apache and you host hasn't turned register_globals back on yet, you should be able to turn them on locally via a .htaccess file. Simply put the following line in the .htaccess file whereever you need register_globals (at the lowest place, the main vBulletin directory). Remember that .htaccess settings are inherited by child directories.

            php_flag register_globals on

            Save and upload it to the correct location.

            And yes, if you're not sure, the filename is literally DOT-htaccess. To save that filename in Notepad, you'll need to surround it with quotes: ".htaccess" . Alternatively, you can upload the file with any filename via FTP and rename it via your FTP client.
            Last edited by Mike Sullivan; Wed 27 Feb '02, 8:10pm.


            • #7
              Thanks Ed.

              Sorry but you be a bit more specific? Which directory would I upload to? Im still learning this. Thanks


              • #8
                ok nevermind. I saw you edited your post. I understand now.


                • #9
                  You can put it in your main web directory (often called 'public_html'.)
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography

                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  • #10
                    The following thread has a longer explanation of this post:

                    Also, although I've only done a quick skim, some people may need to remove the following from at least the newthread/newreply/editpost templates:


                    Although since you need to remove that to post, it's doubtful that your host has attachments enabled right now anyway, keep in mind that without that encoding type, you will never be able to attach files.
                    Last edited by Mike Sullivan; Mon 4 Mar '02, 7:53pm.


                    • #11

                      Thanks guys. The htaccess file worked!

                      I also needed to remove the code from the post templates..before it worked. But that was an easy fix!
                      My forums are postable now.

                      Question now....
                      Should I take down the htaccess file after I am sure the host has installed the patch? - and then insert the code back into the post templates?

                      thanks again guys


                      • #12
                        Will there be a new vbulletin version?

                        Will we see a special vBulletin 2 Version that will run proberly with register globals set to off?


                        • #13


                          • #14
                            Thanks everyone

                            Your fixes were right on the money and
                            a great help when my ISP (PAIR) basically told
                            me to pack sand.



                            • #15
                              I also am hosted with pair networks (, and I tried both the patches but they didn't work. I ended up having to create a .htaccess file which contained the following:

                              php_flag register_globals on
                              php_flag file_uploads on

                              After adding the second line this worked! I hope this will help other pair networks users.


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.