Announcement

Collapse
No announcement yet.

regarding the "no forum specified error"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Hi Warwick,

    I'm not sure why your forum wouldn't be up and running if you've not done anything to it yet. But I can provide the step-by-step in regard to editing your templates ... removing the enctype="multipart/form-data"

    1. In the CP, on the left you'll see the menu, at the very bottom is Templates choose Search from its options.

    2. In the right window a "Search For String" text box will appear (the top choice), enter enctype="multipart/form-data" and click on "Find String."

    3. All of the templates (editpost, modifyavatar, newreply, newthread) that contain that string will be returned. Click on the Change Original link for the first template and the code for that template will appear.

    4. At the bottom of that window is a text field, enter in the string you are looking for (enctype="multipart/form-data") and click "Find." It will be highlighted once found, simply delete it.

    5. Then save the template.

    6. Repeat the steps above for each of the templates.

    Once the long term solution has been applied (php patched/upgraded) you will have to go back and add this string, so take note where you are removing it from.

    I'm not sure if this is all that has to be done. Do contact your host and make sure they turn off file uploads for php.

    vBulletin Support and Experts, please let me (and Warwick) know if I've said something wrong here.

    Hope this helps.

    Destee
    destee.com

    Comment


    • #62
      Ah, sweet...thanks for that - it was easy to understand! I'll try it tomorrow and see if it works.

      Thanks again...
      Warwick

      Comment


      • #63
        i have another problem now.

        i did remove all the enctype stuff, what i did now is, i tried to upload my original style file without luck. is this because of i removed the enctype things or because my host haven't upgraded to 4.1.2 yet? they will do today.

        and, what has my host to turn off or on to have this and file uploads working?

        currently, they have register_globals and file_uploads off... sorry if this is a stupid question, am not into php

        Comment


        • #64
          File Uploads will not work until they upgrade PHP (and only then if they turn them on).

          As to register globals if you look back a couple pages for a post by Ed Sullivan you will find what you need - you have to create an .htaccess file with
          php_flag register_globals on
          in it.

          Comment


          • #65
            Am I the only one that noticed that everything runs smoother and quicker without the entype thing?

            Comment


            • #66
              It works quicker because it is only processing one type of data as opposed to two. However you lose the ability to upload files.

              Comment


              • #67
                HOSTWAY.com and PHP ISSUE

                Because HOSTWAY is only running version 4.06 I had to do the changes to 3 of the template files for my vBulletin to function again.

                Luckily all I had to do was EMAIL tech support at HOSTWAY and they offered to update my PHP to version 4.1.2 for my directories only.

                I am sure this will help anyone hosting with HOSTWAY.COM




                All is good.

                Comment


                • #68
                  Wierd. This is what I got from Hostway. Im not sure what I am supposed to change?!?

                  Hello,

                  Please consult the company on the fix on this issue. You can actually create a PHP.ini file and place it into your CGI-BIN and that will take precedence over the server's PHP.ini file. Please make the possible changes to that PHP.ini file and place it there. This will need to be done so that the vbulletin works. Once this is done, you should not have a problem.

                  Here is a sample php.ini file which you can upload into your cgi-bin:
                  --------------------------------------------------------------------------

                  [PHP]
                  ; $Id: php.ini-dist,v 1.78.2.2 2001/06/01 03:20:49 sniper Exp $

                  ; *HOSTWAY NOTE*
                  ; Other than a few customizations, this is the default php.ini that comes
                  ; in the php distribution from www.php.net. If you are unsure about anything
                  ; contained within, the best place to research is at php's website they
                  ; have a very useull *annoted manual* with user comments.
                  ;
                  ; http://www.php.net/
                  ;


                  ;;;;;;;;;;;;;;;;;;;
                  ; About this file ;
                  ;;;;;;;;;;;;;;;;;;;
                  ; This file controls many aspects of PHP's behavior. In order for PHP to
                  ; read it, it must be named 'php.ini'. PHP looks for it in the cgi-bin
                  ; directory where the php cgi resides.
                  ;
                  ; The syntax of the file is extremely simple. Whitespace and Lines
                  ; beginning with a semicolon are silently ignored (as you probably guessed).
                  ; Section headers ....
                  Snipped!

                  Comment


                  • #69
                    scatpack and hostway

                    if you need any assistance please let me know. It was quite simple once I familiarized myself with where PHP was stored within our HOSTWAY directories.

                    php.ini is located in the CGI-BIN folder.

                    * I asked hostway to upgrade me to version 4.1.2 and they had done that for my directory only.

                    * in Admin Control, I edited 3 template files as to comment out the following:

                    <-- enctype="multipart/form-data" -->

                    No need to do any .htaccess edits



                    Comment


                    • #70
                      agustin,

                      So this really isnt a fix, but a patch? You still can't do attachments right?

                      From the email hostway sent it sounded like this was a fix...but I had to do it myself thru the php.ini

                      Currently my board "works" but I had to disable the attachments by taking out those lines in the template and adding the .htaccess file

                      Comment


                      • #71
                        If PHP has been upgraded to 4.1.2, and your host previously had file uploads enabled, you should ask them to renable them (or in your case you can add the line
                        File_Uploads = on
                        to a php.ini file and put it in your CGI-bin). At that point you can also add the enctype back into the <form> tag in your templates as file uploading should once again work.

                        Comment


                        • #72
                          I am just about to give up!

                          On VB. I have had it for over a year now. For one week my members are unable to post. I still can't get the thing to work right. UGH

                          Comment


                          • #73
                            Have you filled out an official support request?

                            http://www.vbulletin.com/members/support.php
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #74
                              Thank you!

                              I do give up and that is probally the best solution! Thank you for your time.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X