Announcement

Collapse
No announcement yet.

regarding the "no forum specified error"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Restart the web server after setting file_uploads = off. This is a temp. solution but all uploading features go off.

    Comment


    • #32
      Interestingly enough my web host (Ventures Online) just upgraded my server to PHP 4.12. The total tech time charged was only 15 minutes. I'm pretty happy about that!

      As for enctype, I don't believe you have to do this if you've already turned off file uploads in the Admin CP. The same goes for php.ini as well unless you are running other PHP apps that allow file uploads. That's my best guess anyway. As with anything I could be proved wrong.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #33
        Smachol (or other mods here) if I have file_upload = off in php.ini, in the Admin CP if I go to user profile and click on change avatar and select custom avatar and then for file upload via Admincp, that feature is disabled too correct...?

        Comment


        • #34
          I tried the global on in htaccess, and it didn't work (php 4.0.6)

          my forums www.macwrite.com/forums/

          do I need to put anything before/after the php global line?

          This is not good for my forums (and it's late and I can't think anymore)

          Comment


          • #35
            ubbuser: Yes

            Comment


            • #36
              Pair Networks has installed a patched php 4.1.2 with register_globals turned ON and file_uploads=1. It seems to work fine.
              Last edited by Hal; Fri 1 Mar '02, 6:32am.
              Harold Kost

              Comment


              • #37
                I currently have PHP 4.1.0 and went into the php.ini and turned the file_uploads variable to 'Off' and then restarted Apache and the forum seems to work fine but when trying to edit a message I got the following error:

                No post specified. If you followed a valid link, please notify the webmaster

                I went back in for the time being and changed the variable back to "On" to get the forum back to normal.

                Also I added the .htaccess file in the public_html directory. Where did I go wrong?
                http://www.softballfans.com
                The Ultimate Softball Community
                Forums, Bat/Equipment Reviews, Team Page Hosting and more!

                Comment


                • #38
                  I am still having the "No Thread Specified" problem.

                  php_flag register_globals on


                  is on, so I don't know what to do now. Any other suggestions?

                  Comment


                  • #39
                    php_flag file_uploads on

                    Maybe? Thats the one that makes ours work, but I removed the .htaccess file as we are on a shared server and I don't wish to jeapordize or compromise our host's server in any way.
                    SWFans.Net Forums
                    Not Your Average Star Wars Forums.

                    Just a few of the other styles to choose from:
                    Jedi | Streamlined | T-Phantom

                    Comment


                    • #40
                      I found out that the global option is on, but I am still getitng "No thread specified." Any other suggestions on how to get my board working again? I did find out that by turning uploads on in PHP, that the problem is solved, byt that is a dangerious thing to do to the other sites and mine on the shared server I am on.

                      Comment


                      • #41
                        Remember that register_globals thing was just one possibility (and it'd actually cause problems *everywhere* not just there).

                        See my 2nd post in this thread regarding removing the enctype. That will fix the problem.

                        Comment


                        • #42
                          Hello -

                          Contacted my Host Provider - Hostway. They seemed to believe the error is from the 'fileuploads_line' in the PHP.INI

                          Comment


                          • #43
                            I see a couple of posts from folks who said previously they were on tera-byte. This actually goes for anybody having problems but knows that register_globals is ON(of which tera-byte is one)

                            DO NOT use the htaccess, this is only if the host has turned register_global OFF. removing the "enc type" is however a must.

                            for those who have attachments off you MUST still remove the enc type.

                            Dave

                            Comment


                            • #44
                              Yes, I am one of the people on Tera-Byte and no I am not using the .htaccess work around except to go through and temporarily upload it to update someone’s custom Avatar for them. Once I am finished I remove the file.

                              To allow posting on the board I have removed the enctype part from the appropriate areas, until our host resolves the PHP security issues.
                              SWFans.Net Forums
                              Not Your Average Star Wars Forums.

                              Just a few of the other styles to choose from:
                              Jedi | Streamlined | T-Phantom

                              Comment


                              • #45
                                Okay, I have an interesting problem.

                                Only some of my users are reporting having the "No Forum Specified Error" and they all are using the AOL Browser. Nobody has reported this problem who is using IE or Netscape. Only AOL users are having the problem.

                                What can I do to fix this so AOL users can also post if they are using the AOL browser?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X