Announcement

Collapse
No announcement yet.

File attachments not working at all

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • George L
    replied
    Originally posted by captnroger
    eva, thank you for your attempts at helping. Let me tell you all what I know:

    1.) this is a Plesk box
    2.) safe mode is ON in php.ini
    3.) vb options set to safe mode on
    4.) tmp directory was created off httpdocs and chmodded per your instruction
    5.) apache was stopped/started

    same issue. should /tmp go in httpdocs or in httpdocs/forum ??

    I have no http.conf, but found httpd.conf under the psa/apache directory. Could not find reference to the virtual hosts section as you list below in option 2.

    Any other ideas?!?!?!
    hmmm you must have had plesk installed differently see if http://vbulletin.com/forum/showthrea...threadid=37766 helps

    Leave a comment:


  • captnroger
    replied
    eva, thank you for your attempts at helping. Let me tell you all what I know:

    1.) this is a Plesk box
    2.) safe mode is ON in php.ini
    3.) vb options set to safe mode on
    4.) tmp directory was created off httpdocs and chmodded per your instruction
    5.) apache was stopped/started

    same issue. should /tmp go in httpdocs or in httpdocs/forum ??

    I have no http.conf, but found httpd.conf under the psa/apache directory. Could not find reference to the virtual hosts section as you list below in option 2.

    Any other ideas?!?!?!

    Leave a comment:


  • George L
    replied
    you seem to have open_basedir restriction in effect you can either

    Option 1

    1. go into php.ini and turn on safe_mode = on
    2. in vB admin panel set vBulletin options > upload options to

    Safe mode = yes
    and set tmp directory to something like /tmp

    so in ftp that /tmp will be located at /home/httpd/vhosts/gofishohio.com/httpdocs/tmp

    and in shell as root user create /tmp directory at /home/httpd/vhosts/gofishohio.com/httpdocs/tmp

    chmodd /home/httpd/vhosts/gofishohio.com/httpdocs/tmp to 5777

    i.e.

    chmod 5777 /home/httpd/vhosts/gofishohio.com/httpdocs/tmp

    3. then restart apache

    OR

    Option 2
    1. add the /tmp directory at /home/httpd/vhosts/gofishohio.com/httpdocs/tmp to open_basedir in http.conf for your virtual host for your vB forums

    i.e.
    Code:
    <VirtualHost 111.222.333.444>
    DocumentRoot /home/username/public_html
    ServerName www.domain.com
    ScriptAlias /cgi-bin/ /home/username/public_html/cgi-bin/
    php_admin_value open_basedir /home/httpd/vhosts/gofishohio.com/httpdocs:/tmp
    </VirtualHost>
    2. in shell as root user create /tmp directory at /home/httpd/vhosts/gofishohio.com/httpdocs/tmp

    chmodd /home/httpd/vhosts/gofishohio.com/httpdocs/tmp to 5777

    i.e.

    chmod 5777 /home/httpd/vhosts/gofishohio.com/httpdocs/tmp


    3. then restart apache

    ONLY do one of the 2 options above NOT both

    Leave a comment:


  • captnroger
    replied
    http://66.216.66.212/phpinfo.php

    Leave a comment:


  • c0bra
    replied
    are you on a plesk server?

    Leave a comment:


  • nuno
    replied
    have you created /tmp folder?
    Under upload option try to set Safe Mode to Yes

    Leave a comment:


  • George L
    replied
    create a file named phpinfo.php and place this code in it and post the url/link to it from your web site

    <?
    phpinfo();
    ?>

    i.e. yourdomain.com/phpinfo.php

    Leave a comment:


  • captnroger
    started a topic File attachments not working at all

    File attachments not working at all

    Just moved our existing board to a new server, everything is fine but apparently users cannot attached gif/jpeg images to their posts using the file upload feature. When they try and click submit, they get the following vbulletin error:

    The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again.

    Yes, the file is within the minimimum size as per the setting section, it is a good file, and attachments are enabled.

    Any thoughts? I think this is the last problem I have to nail down.

    -Roger

Related Topics

Collapse

  • dacstyle
    error with attachments
    by dacstyle
    I try to upload a 1,5mb zip file to a post, and i have an error about file too big.

    In the admincp i setup usergroup and file extension for unlimited space and also try with a very larger...
    Thu 27th Sep '12, 10:47pm
Working...
X