Announcement

Collapse
No announcement yet.

Upgrade from v.2.2.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Paul M
    replied
    Originally posted by manfai777 View Post
    I can downgrade back to php4 but how do I upgrade to v.4 if it requires php5?
    In two steps, pretty much as posted above by Zachery & beishe8

    With php4 installed, upgrade to vB 3.6.0.

    Once you are there, update to php5, then upload the vb 4.2.0 files and run the upgrade from 3.6.0 > 4.2.0.

    Note that you should not use php 5.4 as that wont play nicely with vb4.

    Leave a comment:


  • manfai777
    replied
    member.php and member2.php did it. Thanks for all the help.

    Leave a comment:


  • Matthew Gordon
    replied
    Try tossing the same code into member.php and member2.php as well. Some files seem to use those variables before calling global.php it seems.

    Leave a comment:


  • Dustin L.
    replied
    Try recovering your password using the steps provided and see if you can login after that.

    Leave a comment:


  • manfai777
    replied
    Thanks for the help. I added the array code in all 3 globals.php file and lines in htdocs\htaccess file. I can now browse and search the forums.
    I still can't login however. When I login, it sends me straight to password recovery:

    If you have forgotten your username or password, you can request to have your username emailed to you and to reset your password. When you fill in your registered email address, you will be sent instructions on how to reset your password.

    Leave a comment:


  • Matthew Gordon
    replied
    For the vB2 installation I have installed on my computer, I use the following in an .htaccess file:
    Code:
    php_flag register_globals on
    php_value display_errors off
    It's likely that register_globals was turned off in your upgrade to PHP5. I believe I also need a few file edits. In global.php, admin/global.php, and mod/global.php, underneath this code at the top of the file:
    PHP Code:
    <?php
    error_reporting
    (7);
    add the following underneath it:
    PHP Code:
    // ***** PHP 5.3+
    $fix_arrays = array(
        
    "HTTP_SERVER_VARS" => "_SERVER",
        
    "HTTP_POST_VARS" => "_POST",
        
    "HTTP_ENV_VARS" => "_ENV",
        
    "HTTP_GET_VARS" => "_GET",
        
    "HTTP_COOKIE_VARS" => "_COOKIE",
        
    "HTTP_SESSION_VARS" => "_SESSION",
        
    "HTTP_POST_FILES" => "_FILES",
    );

    foreach (
    $fix_arrays as $to => $from) {
        $
    $to = $$from;
    }
    // ***** PHP 5.3+ end 
    I won't guarantee that everything will work perfectly, but hopefully things will be functional enough.

    Leave a comment:


  • beishe8
    replied
    Originally posted by manfai777 View Post
    but how do I upgrade to v.4 if it requires php5?
    As Zach said above then:
    Upload vB 4
    Change PHP to PHP 5
    Upgrade your forum.

    Leave a comment:


  • Zachery
    replied
    vBulletin 2 does not work well with php 5 at all. You'd be best off upgrading to 3.8.x if you have access.

    You can upgrade to 3.6 first.

    Leave a comment:


  • manfai777
    replied
    It's not really an error I get back. I just won't log me in as if I provided an invalid password or the user is invalid. If v.2.2.8 does not support php5, I can downgrade back to php4 but how do I upgrade to v.4 if it requires php5?

    Leave a comment:


  • beishe8
    replied
    Originally posted by manfai777 View Post
    I just upgraded to php 5.3.14/apache 2.2.2. I can't seem to login anymore to my 2.2.8 forums, does vBulletin 2.2.8 support php5?
    No,it does not.

    Leave a comment:


  • borbole
    replied
    What error are you getting when trying to logging in?

    Leave a comment:


  • manfai777
    started a topic Upgrade from v.2.2.8

    Upgrade from v.2.2.8

    Hi,

    Our forums is running v.2.2.8 and I would like to upgrade to the latest.
    I have a professional service ticket on this.

    Before I would pass on to vBulletin for the upgrade, I understand that v.4x requires php5.

    I just upgraded to php 5.3.14/apache 2.2.2. I can't seem to login anymore to my 2.2.8 forums, does vBulletin 2.2.8 support php5?
    The front page of my forums seems to load fine.

    Anthony

Related Topics

Collapse

Working...
X