Announcement

Collapse
No announcement yet.

please help, MAJOR problem with searchindex table

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • please help, MAJOR problem with searchindex table

    I've been having problems with our boards for the past few days since trying to run a message prune, which failed after an hour of grinding away. I previously reported this here on this board, and I still need some help!

    Apparently the table searchindex has gone south. I can't reindex from the control panel without an error, I'm getting dozens upon dozens of email errors mailed to me, and the symptoms include replies not showing up on thread counts, and lots of database errors when users try to post. When I look at the table with phpmyadmin, the table searchindex is 'in use'. When I try to browse that table, I get a
    SQL-query :

    SELECT * FROM `searchindex` LIMIT 0, 30

    MySQL said:


    Can't open file: 'searchindex.MYD'. (errno: 145)

    I can run a repair on it either without the same error. What in the world can I do to fix this problem? Delete the file? Can anyone please help??!?!!?

    Thanks.

  • #2
    Do you mean you 'can' or 'can't run repair.php? hat is the EXACT error when you try to run repair?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      when I try to 'look' at this table in phpmyadmin, I get

      SQL-query :

      SELECT * FROM `searchindex` LIMIT 0, 30

      MySQL said:


      Can't open file: 'searchindex.MYD'. (errno: 145)


      It won't even let me browse or otherwise try to repair (in phpmyadmin the only options I get for this table are <insert> and <drop>. I could try to repair from the command line via telnet if you could post the syntax.

      Comment


      • #4
        Close your forum first.

        Upload repair.php to your forums directory (it's in the 'extras' directory of the zip file) and run it from your browser. Choose this syntax:

        repair.php?html=1&check=1
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          running now (keeping fingers crossed, this could take awhile, as it's a 180mb dumped file!)

          Comment


          • #6
            I THINK THAT GOT IT!!! Thanks for your help!!!

            Comment


            • #7
              Excellent!
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X