Announcement

Collapse
No announcement yet.

PHP, ISAPI, Migrating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP, ISAPI, Migrating

    Short story, I need help. Please read this thread. I decided to move it here. The ISAPI error was a fluke, but here's the deal: The admin-panel works, it's slow as syrup and the footer+header seems to be affected by the similar weird characters. I've attached a screen-grab.
    Last edited by Fusion; Sun 3rd Feb '02, 4:21pm.
    Toddler from Hell

  • #2
    are you running ZendOptimizer?
    You're my Prince of Peace
    And I will live my life for You

    Comment


    • #3
      Yes. Don't tell me that bugger's to blame? Or is it just going too fast?
      Toddler from Hell

      Comment


      • #4
        try disabling zendoptimizer and see if that solves the problem
        You're my Prince of Peace
        And I will live my life for You

        Comment


        • #5
          Exactly how would I do that? Commenting out the two lines in php.ini didn't help.
          Toddler from Hell

          Comment


          • #6
            I de-installed ZendOptimizer. Didn't help any.
            Toddler from Hell

            Comment


            • #7
              are you running IIS or Apache?
              have you checked your server log files?
              You're my Prince of Peace
              And I will live my life for You

              Comment


              • #8
                Read the linked post in the initial post. I'm trying to migrate to Sambar, a free windows-based web-server based on Apache to take advantage over its ISAPI-interface rather than my old CGI-based life with the old server. If you have a free moment, feel free to get it at http://www.sambar.com and give it a spin yourself to see if you have any more luck than I.
                Toddler from Hell

                Comment


                • #9
                  oh i c
                  only found this
                  http://www.sambar.com/session/highli...api+&color=red
                  You're my Prince of Peace
                  And I will live my life for You

                  Comment


                  • #10
                    Yes, to make the story short, ALL available dlls have been copied to the system-directory as per the PHP install docs and the correct mapping has been added. As I've said earlier phpinfo() works without a hitch, so why should vB?
                    Toddler from Hell

                    Comment


                    • #11
                      Found the cause. gzip and PHP over ISAPI makes for a bad mix. Wonder if that's a bug?
                      Toddler from Hell

                      Comment


                      • #12
                        Try to add the third line to your global.php

                        PHP Code:
                        @header("HTTP/1.0 200 OK");
                        @
                        header("HTTP/1.1 200 OK");
                        @
                        header("Content-type: gzip");  // <<<--- This One
                        @header("Content-type: text/html"); 
                        Bye
                        Renato

                        Comment


                        • #13
                          Hmm, no, didn't help.. Must be a server-limitation.
                          Toddler from Hell

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X