Announcement

Collapse
No announcement yet.

Either I am doing wrong or Style feature is buggy?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Either I am doing wrong or Style feature is buggy?

    Hi guys, styles are not working fine on my board as they should (or so I think).

    I did the following: Default template I modified.

    Then One custom style I added. This style's properties are:

    Title: stylename
    Replacementset: stylename
    Templateset: default

    Now this style should inherit the templates of the default set templates but it does not?!

    Why is that? I may have modified the "stylename" templates before. Any tips would be helpful thanks.

  • #2
    My advice it to leave the Default style alone and just create new styles along with corresponding replacement and template sets.

    How are you determining that this custom style isn't using the default templates? Do you have another template set? If so, which template set does the 'Default' style use?

    (Belive me, it's much less confusing to do what I suggested in the first sentence.)
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Well I found out the custom style is not using the default templates because when I go to the forum usign that style, it's not showing the mods I have done.

      BTW what's this replacement set feature thing do?

      I still have to get the hang of styles and how they inherit stuff, etc.

      Comment


      • #4
        BTW I am referring to mods in the default templates.

        Well the default style has:

        title:default
        relplacement set:default
        templateset:default

        Comment


        • #5
          But if it's not using the default template set, then it must be using another one.

          Again do you have more than one template set? If so, which template set does the 'Default' style use? If not, then it must be using it since there's only one it can use.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            This gets even more weird. When I go to that style's properties, and use the drop down menu to select the "template set" it's showing 3 instances of "Default" templates!

            When I go to the main styles it does not show any multiple instances of Default styles.

            How do I fix this multiple instances of "Default" Templates showing up and how'd they show up anyways?

            Comment


            • #7
              Yep that fixed things, I went to the templates list and deleted the multiple instances of the "default" templates. Y these got created I have no clue yet.

              So you are advising I create a new template set, and modify that, and leave the default template set alone? Now that I have modified it, how do I reset the default template set to its original properties?

              BTW is there any way I can copy templates? So maybe I can make a copy of the default template, rename it, and use that across all forums.

              I have another question: The header tags, etc. why do not they get inherited from the Style itself ? What I am seeing is that when I make a custom style as follows:

              Stylename
              Replacementset: stylename
              Template set: default

              This style then inherits all the values of the header, footer tags from the template set. I thought it'd inherit its own values of "header", "footer" tags ?

              Comment


              • #8
                Yes, you're definitely better off just leaving the default set alone and use a new replacement and template set for each style you create.

                Unfortunately there's no template copying function. You can download a style set, then upload it again. However as you'll see it gets uploaded with the same name. You then need to change the name of the style, replacement and template sets that you just uploaded so you don't get too confused. This entire system will be much easier to understand and administrer in version 3.

                The header and footer are templates.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X