Announcement

Collapse
No announcement yet.

weird vB behavior - please help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • weird vB behavior - please help

    Hi,

    I run FutureProducers.com, things are great and I love my vB 2.x. There was no problem whatsoever, until.........


    .......... about one week ago, everytime someone would post a message or a thread, they would see a mySQL error (you know, the "there has been a slight problem...". If they refreshed the page, they'd post. OK they'd post, but the thread counters and order wouldnt change

    So...

    So this morning I closed the forum, logged via SSH and did a mysqldump backup. Then I ran myisamchk -s and -r, -s again to double check, apparently the whole thing was clean and repaired. I restarted mySQL and opened the forum again.


    All day today, things were smooth again. Tonight though, I saw one of those error messages when posting (no all the time... yet).... SAME problem is starting to happen again...


    I would like some help, whether you think there is something wrong with my server config / tweaking or if I should upgrade the forum version (known issue after a while?), or...

    Thanks in advance for all your help.
    This is important, +10.000 members will thank you

    Sincerely,

    -mano
    design and technology / mano1.com
    resource and community for musicians / FutureProducers.com

  • #2
    What was the exact error message? This would be in the email sent to the technical contact in the config.php file.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thanks for posting smachol, hopefully we'll fix this problem

      Aaron (of were-here.com) told me to look at the source code of the error page, so here we go:


      <!-- Database error in vBulletin: Invalid SQL: DELETE FROM searchindex WHERE postid IN (103978,99665,99733,0)
      mysql error: Incorrect key file for table: 'searchindex'. Try to repair it
      mysql error number: 1034

      Date: Saturday 02nd of February 2002 07:25:45 PM
      Script: /board/postings.php
      Referer: http://www.futureproducers.com/board...threadid=14630
      -->



      This appeared when I tried to delete a thread on the forum
      I bolded the "important part".

      It also happens when you try to post a regular post, but I assume the error message will be different.
      design and technology / mano1.com
      resource and community for musicians / FutureProducers.com

      Comment


      • #4
        Originally posted by ManoOne
        thanks for posting smachol, hopefully we'll fix this problem

        Aaron (of were-here.com) told me to look at the source code of the error page, so here we go:


        <!-- Database error in vBulletin: Invalid SQL: DELETE FROM searchindex WHERE postid IN (103978,99665,99733,0)
        mysql error: Incorrect key file for table: 'searchindex'. Try to repair it
        mysql error number: 1034

        Date: Saturday 02nd of February 2002 07:25:45 PM
        Script: /board/postings.php
        Referer: http://www.futureproducers.com/board...threadid=14630
        -->



        This appeared when I tried to delete a thread on the forum
        I bolded the "important part".

        It also happens when you try to post a regular post, but I assume the error message will be different.
        what version of mysql are you using ?
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          Tube,

          Couldn't ManoOne just rebuild the search index to fix this?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I just did (rebuild the search index) this morning, right after repairing the db, it didnt stop the problem

            MYSQL VERSION: 3.23.45

            thanks guys!


            ps: just got the error again, when posting this time... it still talks about the searchindex. im going to try to empty it, repair my db again and rebuild it...
            Last edited by ManoOne; Sat 2nd Feb '02, 8:13pm.
            design and technology / mano1.com
            resource and community for musicians / FutureProducers.com

            Comment


            • #7
              Originally posted by ManoOne
              I just did (rebuild the search index) this morning, right after repairing the db, it didnt stop the problem

              MYSQL VERSION: 3.23.45

              thanks guys!


              ps: just got the error again, when posting this time... it still talks about the searchindex. im going to try to empty it, repair my db again and rebuild it...
              or you can try repairing it, recheck for corruption and then dumping to sql file the database and reimporting it into a new empty database
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                that's a clever idea eva! an empty database. sweet! ill try that next then

                thank you
                design and technology / mano1.com
                resource and community for musicians / FutureProducers.com

                Comment


                • #9
                  Originally posted by ManoOne
                  that's a clever idea eva! an empty database. sweet!

                  ok ill try that next then
                  thank you
                  yeah i try to avoid reindexing searchindex when ever possible as it takes forever when you have alot of posts/threads... took me 3 - 4 days for my forum when i changed my min/max words to index
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    now it does it when you click on a member's name (in the thread list):

                    http://www.futureproducers.com/board...threadid=15379


                    Warning: MySQL: Unable to save result set in /home/prod1/public_html/board/admin/db_mysql.php on line 92




                    aargghh!

                    Yesterday I repaired the DB with myisamchk (both -r and -o) and rebuilt the searchindex... Didnt fix


                    This idea of the empty db sounds interesting, I think i'll do this next...



                    Its funny, i think it all started to happen when I created a new private forum lately... How can this affect the whole engine so much though?
                    design and technology / mano1.com
                    resource and community for musicians / FutureProducers.com

                    Comment


                    • #11
                      when I run myisamchk -s look at the text that's generated:

                      myisamchk: ISAM file /var/lib/mysql/prod1_community/adminlog.MYI
                      myisamchk: error: Size of datafile is: 760518 Should be: 771144
                      myisamchk: error: Found key at page 25600 that points to record outside datafile
                      MyISAM-table '/var/lib/mysql/prod1_community/adminlog.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/forum.MYI
                      myisamchk: error: Record at pos: 52712 is not remove-marked
                      myisamchk: error: record delete-link-chain corrupted
                      myisamchk: error: Key 1 doesn't point at all records
                      MyISAM-table '/var/lib/mysql/prod1_community/forum.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/post.MYI
                      myisamchk: error: Size of datafile is: 37946904 Should be: 37974256
                      myisamchk: error: Found key at page 4291584 that points to record outside datafile
                      myisamchk: error: Record-count is not ok; is 101583 Should be: 101639
                      myisamchk: warning: Found 101583 parts Should be: 101644 parts
                      MyISAM-table '/var/lib/mysql/prod1_community/post.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/privatemessage.MYI
                      myisamchk: error: Size of datafile is: 2013640 Should be: 2014936
                      myisamchk: error: Record at pos: 1707772 is not remove-marked
                      myisamchk: error: record delete-link-chain corrupted
                      myisamchk: error: Found key at page 87040 that points to record outside datafile
                      myisamchk: error: Record-count is not ok; is 4405 Should be: 4389
                      myisamchk: warning: Found 0 deleted blocks Should be: 18
                      myisamchk: warning: Found 4405 parts Should be: 4413 parts
                      MyISAM-table '/var/lib/mysql/prod1_community/privatemessage.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/searchindex.MYI
                      myisamchk: error: Size of datafile is: 20084680 Should be: 20099871
                      myisamchk: error: Found key at page 8041472 that points to record outside datafile
                      MyISAM-table '/var/lib/mysql/prod1_community/searchindex.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/thread.MYI
                      myisamchk: error: Wrong bytesec: 0-0-0 at linkstart: 1235892
                      MyISAM-table '/var/lib/mysql/prod1_community/thread.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/user.MYI
                      myisamchk: error: Size of datafile is: 1418232 Should be: 1418252
                      myisamchk: warning: Found 10073 parts Should be: 10074 parts
                      MyISAM-table '/var/lib/mysql/prod1_community/user.MYI' is corrupted
                      Fix it using switch "-r" or "-o"
                      myisamchk: ISAM file /var/lib/mysql/prod1_community/word.MYI
                      myisamchk: error: Size of datafile is: 9312050 Should be: 9318815
                      myisamchk: error: Found key at page 3701760 that points to record outside datafile
                      MyISAM-table '/var/lib/mysql/prod1_community/word.MYI' is corrupted


                      aaagghhh it is amazing how the whole thing just breaks down a few hours after everything has been repaired and cleaned...



                      ... OK just launched a myisamchk -o -e (WITH extended checking) and I see my screen filled with these lines:

                      Found block with too small length at 8424888; Skipped





                      Could it be some settings in my httpd.conf or php.ini or something like this? Someone at my host recently changed the hard disk of my dedicated server... He could have changed osmething int he settings? It was working super fine for 2 years or so! Actually it was working fine for some time after he changed the hard drive too.. im lost!

                      I appreciate the support though keep it coming
                      Last edited by ManoOne; Sun 3rd Feb '02, 12:18pm.
                      design and technology / mano1.com
                      resource and community for musicians / FutureProducers.com

                      Comment


                      • #12
                        ok i just successfully repaired, checked, and backed up my forum database. I am reopening the forums for now and if this whole thing happens again I'll go with Eva's latst idea.

                        thanks
                        design and technology / mano1.com
                        resource and community for musicians / FutureProducers.com

                        Comment


                        • #13
                          Originally posted by ManoOne
                          ok i just successfully repaired, checked, and backed up my forum database. I am reopening the forums for now and if this whole thing happens again I'll go with Eva's latst idea.

                          thanks
                          did you run myisamchk with mysql shut down first ?
                          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                          :: Nginx SPDY SSL - World Flags Demo [video results]
                          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                          Comment


                          • #14
                            yes, I did.

                            It is WORKING right now (! yay !) so apparently I got it all to be repaired at some point. I didn't use your empty-db trick though (I will, in case it happens again).

                            So far so good...

                            Ah there is still this weird mail notification which stopped working 3 months ago for some reason... ah it still works for old threads (interesting!). I should post a new thread about that...

                            thanks again! I will probably update to 2.2.2 soon... do you recommend it?
                            design and technology / mano1.com
                            resource and community for musicians / FutureProducers.com

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X