Announcement

Collapse
No announcement yet.

Installation step 3 problems...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation step 3 problems...

    I'm getting this error message:

    Attempting to attach to database...


    Warning: MySQL Connection Failed: Access denied for user: '[email protected]' (Using password: YES) in /home/ota000/www/forum/admin/db_mysql.php on line 40

    Warning: Supplied argument is not a valid MySQL-Link resource in /home/ota000/www/forum/admin/db_mysql.php on line 47

    The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.
    The data I uploaded with config.php is correct, a MySQL database was assigned to me by my web host.

  • #2
    AKAIK the only way you would get this error is if one or more of the following variables were wrong in you config.php file:

    dbusername
    dbpassword
    dbname

    Make sure you are using your db name and password and not your account name and pw.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by smachol
      AKAIK the only way you would get this error is if one or more of the following variables were wrong in you config.php file:

      dbusername
      dbpassword
      dbname

      Make sure you are using your db name and password and not your account name and pw.
      I have double checked that, I'm using the right name/password and database name.

      Comment


      • #4
        Are you sure you should be using matijavujica.com instead of just localhost as the server?

        Comment


        • #5
          Ah, I missed the localhost thing!
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I'm still getting the same error. I contacted my host, and they told me that nobody/nothing tryed to log on to that account.

            Comment


            • #7
              Originally posted by Elessar


              I have double checked that, I'm using the right name/password and database name.

              Try a 'dumb' script that will just make a database connection with the provider database name, username and password, that will only say: Connection: OK (and when fails) Connection: Failed

              Then upload the dumb.php script to your server and see ..

              dumb.php
              Code:
              <?php
              // replace localhost with an ip address if required by web host
              // replace username with your mysql username
              // replace password with your mysql password
              // replace databasename with your mysql database name
              // save this source as dump.php and upload to your server, run it .. 
              $connect = @mysql_connect(localhost, username, password) or die("<p>Connection failed");
              $database = @mysql_select_db( databasename, $connect );
              if($connect){
              print "<p>Connection OK";
              }
              ?>
              With this you at least know that you can connect to that host with that l/p combination. Hope it helps. SORRY if my code has an (possible) error,.. it is late here, and I just made this by head.

              Comment


              • #8
                Thanks for the little script, it failed to connect, but I have sent it to my host and told them to tell me if there is something wrong with the data. I'm waiting for an answer.

                Comment


                • #9
                  Now I got that little dumb1.php script to work by using the localhost settings, but the real thing(install.php) is still giving me the error.

                  Comment


                  • #10
                    If you're getting the same error then my first post in this thread applies. Are you sure your host doesn't reuire some sort of prefix (usually your username) in front of the dbusername and dbname?

                    Do you have phpMyAdmin? Can you log into that db with it? What's the exact username and password required to do that?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by smachol
                      If you're getting the same error then my first post in this thread applies. Are you sure your host doesn't reuire some sort of prefix (usually your username) in front of the dbusername and dbname?

                      Do you have phpMyAdmin? Can you log into that db with it? What's the exact username and password required to do that?
                      I can log using phpMyAdmin without any problems. I really don't understand why only vBulletin isn't working, and everything else is.

                      Comment


                      • #12
                        when I try to go to your site I'm told I'm not authorized to view the page, so I can't offer any help.
                        Webmaster:
                        @forumz

                        Comment


                        • #13
                          Originally posted by Martin
                          when I try to go to your site I'm told I'm not authorized to view the page, so I can't offer any help.
                          You must use this url:
                          http://otakuheaven.org/forum/

                          or

                          http://otakuheaven.org/phpMyAdmin/

                          Comment


                          • #14
                            Originally posted by Elessar


                            You must use this url:
                            http://otakuheaven.org/forum/

                            or

                            http://otakuheaven.org/phpMyAdmin/
                            I can't belive that nobody knows how to fix the problem...

                            Comment


                            • #15
                              Sorry, but I still think it's a probelm with the variables in your config.php file. For instance i noticed that no username or password was required to view that phpMyAdmin link you gaqve us.

                              I suggest you fill out an official support request at:

                              http://www.vbulletin.com/members/support.php

                              Be sure to provide the info for telnet and ftp access to the account on your host. This will be needed for Support to solve the problem.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X