No announcement yet.

How to set up avatars so only certain usergroups can use them?

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to set up avatars so only certain usergroups can use them?

    How can I set up avatars so that a particular usergroup can use them? I only want admins, mods, and prefects to be able to have avatars. Is this possible? If so, how?

  • #2
    Currently this is not possible without manually adding an avatar to each user.


    • #3
      I am having the same problem. My problem is that I want only administrators to have Avatars. I only have 5 admins on the board.

      I disabled Avatars in VB Options, and then went to each user profile and clicked on "Change Avatar" and assigned them an avatar. However, the avatars still don't show up on the threads. I even tried logging in and out, and even putting up a new post to 'refresh' my profile.

      I know it will show up if I enable Avatars in VB Options, but that will enable it for everybody, and I only want to enable it for 5 people.

      Is there a way to go about doing this? Any help is appreciated, thanks.


      • #4
        You need to turn avatars on (and I believe leave Allow Uploads on) for it to show them, but you can set the Minimum Custom Posts to, say, 50000 and then individually add avatars for the users you want. They should then show up.


        • #5
          Thanks for the reply. One thing though- in the upload avatar page, doesn't it ask you to put in the minimum # of posts to choose that avatar? Doesn't that allow regular users to choose that avatar thats already in the system?


          • #6
            You should not use that as, yes, that will allow your normal users to choose them.

            You should individuall assign your users custom avatars by going to Users > Find > put in their username and hit submit > click [edit] next to their name and click the Change Avatar button on the resulting page.


            • #7
              Okay, I enabled Avatars, put 100000 as minimum posts for users to choose custom avatar (this is all in VB options), I erased my Avatar DB by going to Modify Avatars, and removing all of them. I then went to my username, went to edit -> Choose Avatar, and specified a URL. It submitted, but I still don't see my avatar in my posts or in my profile.

              Am I doing something wrong?

              Edit: Actually, I made a mistake. I go to Choose Avatar -> choose Yes for "Add Custom Avatar?" and then specify the URL (the .gif file that I want to use is stored locally in the vB directory). I type in the full path, i.e., and then hit submit, it 'waits' and then it says "Error - cannot find an image at the specified URL. Please make sure that you have entered a valid URL."

              Update: Okay, while what I mentioned above didn't work, doing the File Browse way works. My question is how come the specifying a URL option didn't work, and also, where does it store the images I upload via the user's Edit -> Choose Avatar screen?

              Thanks so much for all your help.
              Last edited by avazee; Wed 30 Jan '02, 3:46pm.


              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.