Announcement

Collapse
No announcement yet.

Problems with Importing Ubb5 to vBB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Importing Ubb5 to vBB

    Hi guys,

    I did a test run and found the following probs (probably because of the fact that I un'tarred a UBB install, and some of the perms were not set right for some settings file?):

    1. The individual forum style settings did not get imported, only the mainforum style got imposed onto the individual forum style for all forums. I think I know the prob but I will ask someone here, my forumstyles.file for each forum directory in UBB is only ugo+r. Should it be chmod 777'ed?

    2. All the post newtopic/postreply icons are still pointing to my old UBB images directory None of them are customized as it should be for each forum (as I set it up in UBB)

    3. I guess this is UBB's fault, but if a forum was previously private, but now public, there is a private forum directory left over in that particular forum's directory. I think the import script reads this private forum's thread and ignores the new public forum's threads? I noticed this because a previously private forum turned public has 100+ threads, but the imported forum in vbb shows 0 threads.

    4. I think this has been discussed in another thread. The smilies are not converted properly. I download the smiliesfix.txt file and will check it out.

    My last question is, since this is a test run, how do I start over again? I do not want to import users now, since all Members were imported fine! I just want to import the individual forums, their individual styles, the messages in them, and fix these post icons/smilies.

    Any tips would be greatly appreciated. So far things look pretty good and better than I hoped it'd be

  • #2
    Alrighty I guess I could set each forum's style again. But it would have been great if the import script would have transferred individual forum styles also instead of just the main forum style? Or it didn't do the import for each style because the file forumstyles.file was only gou+r and nothing else..?

    I could also fix the icons by going thru the CP.

    However some of the above issues still remain. Any suggestions would be appreciated a lot.

    Comment


    • #3
      Alrighty I was able to delete the private forums and all messages and users seem to have imported fine

      The prob for some weird reason is with the "post message icons" (icon1.gif, icon2.gif etc.). What's the best way to fix this because some messages are being imported with empty values for the IMG SRC tag that is, "img src="" "

      Why some messages? One piece of info is that my icons on the UBB icons folder are not sequential (1, 2.gif .. so on) in numbering, some numbers are missing. Could that create probs with importing?

      Plus each style for each forum does not get imported. Even though I fixed the perm bits for all forumstyles.file for each forums.

      Thx!

      Comment


      • #4
        I believe only the ubb6 importer will grab each style so if you wish to upgrade your ubb to v6 first than import you can achieve what you wish.

        Comment


        • #5
          Originally posted by ubbuser
          The prob for some weird reason is with the "post message icons" (icon1.gif, icon2.gif etc.). What's the best way to fix this because some messages are being imported with empty values for the IMG SRC tag that is, "img src="" "
          I fixed these after my UBB import by adding this line to the smiliefix.php file:

          Code:
          $text = str_replace('<img src="" alt="" border="0">', ' ', $text);
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Running smiliefix.php

            Hello, thanks for the reply. Styles for each forum does not matter much as I can apply new styles later on.

            However the main issue left for now is this post message icons that seem to be disappearing in the IMG SRC tag.

            The version of smiliefix.php file I have is as follows (I have added ##### next to the img tags so that this forum does not parse it as a vbb code or smilie:

            PHP Code:
            <?php

            require('./global.php');

            function 
            translatesmilies($text) {
              
            $text str_replace('[img#####]http://www.dvdplaza.com.au/dcafe/smile.gif[/img]'':#####)'$text);
              
              
            // duplicate the above line for other smilies //
              
              
            return $text;
            }

            $posts=$DB_site->query("SELECT postid, pagetext FROM post WHERE pagetext LIKE '%[img#####]%'");
            while(
            $thispost=$DB_site->fetch_array($posts)) {
              
            $fixed translatesmilies($thispost['pagetext']);
              
              
            $DB_site->query("UPDATE post SET pagetext='".addslashes($fixed)."' WHERE postid=$thispost[postid]");
              echo 
            "$thispost[postid] done.<br>\n";
            }

            ?>

            Smachol, where do I add the line you mention, and how do I run this php script? command line or via a web browser? Thanks!

            Comment


            • #7
              You add it to the smiliefix.txt file you downloaded. Put it right after the other $text statements. You then rename that file to smiliefix.php and run it from your browser. I believe the full instructions are in the thread where you got smiliefix.txt. This fixed all the broken image icons I had left over from my UBB import.

              As always, be sure to make a backup of your database before running any commands that affect the db.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Smachol I'm a bit unclear about this script.

                Do I have to add lines referring to the smilie.gif file's url for every smilie icon in this script?

                Or just one smilie? I will read the original thread too.

                Comment


                • #9
                  It's been a long time since I ran this script but luckily I kept a copy of it. Here's what I used for my forums. You should be able to figure out what needs to be changed for yours.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks much, I will run it in a few hours, I hope you'll linger around later on so that if I have further questions you might be able to help me out Have a good day!

                    Comment


                    • #11
                      BTW that extra line you mentioned, does it fix the "post message icons" ? I'm referring to the icons next to the folder icons in each forum display columns.

                      Comment


                      • #12
                        Hi, my empty Post message icons URL code is as follows:

                        <img src="" alt="" width="15" height="15" border="0">


                        Therefore, I tried replacing the img src tag you mentioned above with the tag I mention above. However running the script did not fix these empty tags.

                        The script however does fix the smilies

                        So the question is, how to fix the empty post message icons?

                        Comment


                        • #13
                          Never mind, the sql queries given in the thread Ed posted in fixed things. Now I have to run that script for the smilies and I should be through most import probs Now for a final install/import !!

                          Comment


                          • #14
                            ubbuser ...

                            Never mind, the sql queries given in the thread Ed posted in fixed things.
                            Which thread was that? I have the same problem.

                            Thanks.
                            http://www.nwboating.net
                            http://www.northwestdiver.com

                            Comment

                            Loading...
                            Working...
                            X