Announcement

Collapse
No announcement yet.

cookie problem with new host

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cookie problem with new host

    ok, i'm running vb 2.2.1, and have just recently changed hosts. before changing hosts, i backed up/downloaded the vb.sql and uploaded it to the new server and restored fine without a hitch. i also uploaded the files for vb and it works fine as well, except for cookies. there appears to be a cookie problem with the new server, and the new host says everything is there for cookies to work, he has tested cookies on my server and they work fine (outside of vb).

    because the cookies don't work, all users must re-login to the forum when they close their browsers and re-open them, AND i cannot login to the admin cp because it says it's a bad password even though i'm logged in fine to the actual forum (and can do normal admin things like edit/move/delete anyone's posts). my other admin cannot login to the admin cp either, gets the same error. my host has recommended me to re-upload the files in ascii mode, but that didn't appear to work.

    so ultimately is there anything to do (in either editing files on the server or thru phpmyadmin) that i can get the cookies to work? i'm thinking maybe they got disabled somehow in the admin cp options with the server switch. TIA.
    http://www.somethingleet.com - the forum of the free // graphics/web design forum.

  • #2
    In admin cpanel on the old server what does this say

    Cookie Domain
    The domain on which you want the cookie to have effect. If you want this to affect all of yourhost.com rather than just forums.yourhost.com, enter .yourhost.com here (note the 2 dots!!!). Can be left blank. ?

    And also Path to save Cookies?

    Comment


    • #3
      in the old server, for 'Cookie Domain', it's blank.

      'Path to save Cookies' is /

      update: i finally hacked my db and got in the admin cp using my encrypted pw, which is kinda strange, but hey it works. i checked the same above settings and they are the same for the new server. any more advice? also i found a possible fix for users having to login every time they go to the site, so i'm seeing what that does. i'd like to just be able to login without having to use the encrypted pw. i can change my encrypted pw in the user table using phpmyadmin to my regular pw, but that's not having too much security in the db itself with no more encrypted pw. any other suggestions would be appreciated.
      http://www.somethingleet.com - the forum of the free // graphics/web design forum.

      Comment


      • #4
        I just switched hosts and experienced the same problem.. what was your solution?
        "Twenty years from now you'll be more disappointed by the things you didn't do than by the ones you did."
        - Mark Twain

        Comment


        • #5
          I'm having the same problem...it started when I changed my cookie setting in the admin cp from it's default of nothing to mydomain.com.

          I experienced the problem too when testing. Deleting the old cookie provided a fix though but many members email me daily with this problem still.

          Should I change the cookie to ".mydomain.com" with the 2 dots? Could this be the problem because I left off the first dot?
          Marc
          -------

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X