Announcement

Collapse
No announcement yet.

MYsql DB error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MYsql DB error

    hi
    i have a forum at http://pgamers.com and we get countless error messages like this one at our boards:

    Warning: Too many connections in /home/vhosts/gsn/pgamers.com/subdomains/ubb/htdocs/admin/db_mysql.php on line 38

    Warning: MySQL Connection Failed: Too many connections in /home/vhosts/gsn/pgamers.com/subdomains/ubb/htdocs/admin/db_mysql.php on line 38



    is there any way i can fix this? im kinda new at this and ive been looking at other topics that are simillar but i do not know if some of the solutions would apply for me. im running MySQL 3.23.47 and phpMyAdmin 2.2.3. if there are any tips or suggestions you can give me i would appreciate them greatly.

  • #2
    Please follow the instructions in the last line of my sig to show you are a licensed customer. Once you've done that, post in the appropriate vBulletin 2 support forum. Thanks!
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      ok all done

      Comment


      • #4
        Thanks! I've moved this thread to the Trouble-Shooting forum.

        Are you on a shared or dedicated server? If you're on a shared server, then you'll need to ask your host to increase the amount of allowable mySQL connections. You could try shutting of 'persistent connections' in your config.php file (view the file to ee what changes you need to make) to see if that will help. If not, then you're at the mercy of your host.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          yes im basically at the mercy of my horrible host, i will contact him shortly. thanks

          Comment


          • #6
            i have yet to recieve a reply from my host (way to go gamesquad) but i do remember that the mysql database that we are on was made specifically for our forums we have our own mysql cp at http://delta.gamesquad.net/tools/mysqladmin/ is there any way i can fix my problem from there?

            Comment


            • #7
              have you made sure persistent connections are off?
              open /admin/config.php

              make sure $pconnect = 0;

              if it is then your host needs to edit the php.ini file and change
              mysql.max_links to a larger value, to allow more connections.

              Hope this helps
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                Thanks PPN persistant connections was on(set to 1) and im uploading the changed config.php as i write this. ill know by the end of the day if this works.

                thanks again

                Comment


                • #9
                  I'll presume your not rick who i use to talk to on ICQ

                  i own PPN Forums btw
                  i'm glad we got that flamewar problem under control with pgamers
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    Originally posted by Guichi
                    Thanks PPN persistant connections was on(set to 1) and im uploading the changed config.php as i write this. ill know by the end of the day if this works.

                    thanks again
                    Hmmm...I suggested the same thing earlier in this thread. This is the second time today this has happened to me. I must be invisible!
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by PPN
                      I'll presume your not rick who i use to talk to on ICQ

                      i own PPN Forums btw
                      i'm glad we got that flamewar problem under control with pgamers

                      nope im definetely not rick, hes gone now and ive taken over pgamers. i was off on a short hiatus when the flames started but i dont let crap like that go on while im around. i was a member of PPN forums when they first opened

                      smachol sorry i wasnt paying attention, when i saw the mercy of your host statement i turned into a manic depressant.

                      Comment


                      • #12
                        Originally posted by smachol
                        I must be invisible!
                        Who said that???


                        Scott MacVicar

                        My Blog | Twitter

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X