Announcement

Collapse
No announcement yet.

Plesk + vB Upload Solution

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • giorgino
    replied
    Hi all... I have the same problem ... 7 years later! oO
    It's possibile tu solve with Plesk 9.5.2? Please help me

    Leave a comment:


  • drumsy
    replied
    I'm trying to install SSH, but those links in the first post are invalid. Is there more updated ones that can be provided, as well as what I need to type to shut down MySQL and reboot the server? Once it is rebooted, do I need to enter a command to start MySQL again?

    Leave a comment:


  • XTR3ME
    replied
    for ease of chmod'ing and some other helpful things
    you can also give the user rights to bash or whatever shell you desire.

    vi /etc/passwd

    find the username you need and the very last line should say false, you want to change this to bash or what ever shell you may want. I would only recommend this if you are the server admin and this is one of your domains. Giving this right to users or resellers lets them browse the entire directory structre which is NOT good.

    Leave a comment:


  • George L
    replied
    Originally posted by randychase
    Thanks again. That was it. I very much appreciate all the help you give me (and the VB community!).
    no probs

    Leave a comment:


  • randychase
    replied
    Thanks again. That was it. I very much appreciate all the help you give me (and the VB community!).

    Leave a comment:


  • George L
    replied
    in the directory containing the file you want to edit/rename

    you can rename it

    mv oldfilename newfilename

    or delete it

    rm filename

    Leave a comment:


  • randychase
    replied
    Sorry for the simple question, how does one delete using SSH?

    Leave a comment:


  • George L
    replied
    try remove the vhost.conf file for the 2nd forum you did and restart apache does that work ?

    if it does i'd double check your typing for the 2nd forum domain's vhost file

    Leave a comment:


  • randychase
    replied
    Yikes. It all seemed to work. I was able to upload a test image. Then I did it for my other forum, replacing the domains with the new domain. Save that one to the proper directory. Rebooted the apache server using the command above. Received this message:

    pcbstandards.# /usr/local/psa/admin/bin/my_apci_rst
    psa: failed to restart Apache server
    0
    Now, I have lost all access to my websites. I can log into the dedicated server using SSH or LeapFTP, but none of the domains load. Help? Was there something I typed to turn off my domains? I am logged into the root now.
    Last edited by randychase; Sat 10th Aug '02, 12:18pm.

    Leave a comment:


  • randychase
    replied
    THANKS!!!! These pesky details.

    Leave a comment:


  • George L
    replied
    Originally posted by randychase
    Hi, I can't seem to figure out how to enable persmissions to write to the /conf directory.

    SSH gives me an error message saying I don't have permission to write the file. Using FTP, I can't do anything in this directory. I tried using CHMOD to 777 for it. Anything else? Thanks!
    you can't write to those files as a normal user you need to switch to root user to do that

    in telnet type

    su -

    which will prompt you for your root server password

    Leave a comment:


  • randychase
    replied
    Hi, I can't seem to figure out how to enable persmissions to write to the /conf directory.

    SSH gives me an error message saying I don't have permission to write the file. Using FTP, I can't do anything in this directory. I tried using CHMOD to 777 for it. Anything else? Thanks!

    Leave a comment:


  • Merlin3649
    replied
    anyways, the first post in this thread is erroneous in certain places. Here's a cleaned up version (which admittedly I compiled through posts in here, Eva's thread on the same subject and another thread in the plesk forums, and the advice from my telnet guru):

    (This is for Dedicated Servers, although the procedure is similar to non-dedicated)

    1. Log into your server via SSH and switch to root if you need to.

    2. run this command, change domain.com to your domain name.

    pico -w /usr/local/psa/home/vhosts/domain.com/conf/vhost.conf

    3. After that has been run, input the following. Be sure to type this as is, except for changing the domain of course :P

    <Directory /usr/local/psa/home/vhosts/domain.com/httpdocs>
    php_admin_value safe_mode 0
    php_admin_value open_basedir "/usr/local/psa/home/vhosts/domain.com/httpdocs:/tmp"
    </Directory>

    4. Be sure to save and exit this file once you make those additions.

    5. Next restart Apache by running:

    /usr/local/psa/admin/bin/my_apci_rst

    after about 5-10 minutes (or however long Apache takes to restart), your avatars _should_ be uploading fine now. Be sure that under your VBulletin Options Control Panel you have Safe Mode turned off. It worked for me at least :P

    Leave a comment:


  • Giansa
    replied
    are u sure that the the procedure works also with plesk 2.5?

    Leave a comment:


  • Steve Machol
    replied
    Yes, any directory that is chmod'd to 777. You need to use the *full and exact* path though.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X