Announcement

Collapse
No announcement yet.

Table 'user' is read only

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Table 'user' is read only

    mysql error: Table 'user' is read only
    mysql error number: 1036
    Date: Monday 07th of January 2002 06:24:08 PM
    Script: /register.php
    Referer: http://forums.gamecubexl.com/register.php

    I'm receiving this error now and I don't know how to fix it. Please help.

  • #2
    are you on a dedicated server or a shared one?
    do you have permissions to modify tables in your mysql db?
    You need full permissions to the tables...

    Query, Insert, Delete, Update
    There are only 10 types of people in the world: Those who understand binary, and those who don't

    Comment


    • #3
      The user table is the only one that needs it.

      How do I give it full permissions. Is it possible to do it through PHPMyAdmin

      Comment


      • #4
        check the mysql data files in mysql data directory to see if they have the correct permissions
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          Only my host can do that.

          Can he CHMOD the files? If not, please give me steps.

          Comment


          • #6
            if only you host can do that they'll have to check if your forum database files in the data directory have the correct permissions
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment


            • #7
              My host kinda needs instructions on how to do it. He doesn't know how to change permissions.

              Well, here's the situation on how this happen.

              One of my admin pruned my members and I lost about 1,800 members. I had a backup of the members, so my host uploaded it to the MySQL database and overwrite the old one. Everything shows up, but when I post or register it gives the error. I figure the permission is the problem, my host is trying to figure it out, but if he can't, can you just give a little step on how to do it. Thanks.

              Comment


              • #8
                Make sure the user.MYD and user.MYI files in the database directory are chmod'd and chown'd the same as the other database files. These should be 660 and owned by 'mysql'.
                Last edited by Steve Machol; Mon 7th Jan '02, 9:46pm.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Alright, I will tell my host to do that. Thank you... if I'm still experiencing errors, I will come back to these trusty support forums.

                  Also, it's user.ISD and user.ISM... Not user. MYD and user.MYI. I'm not sure if it makes a difference, but I'm going to try.
                  Last edited by Heero; Mon 7th Jan '02, 9:43pm.

                  Comment


                  • #10
                    It sounds like you're using an older version of MySQL than I am. Good luck!

                    P.S. I just noticed that you said your host doesn't know how to change file permissions. Is that right? I can't believe a reputable web host wouldn't know how to do something that basic.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Heh, thanks.

                      Hmm, this might be a problem if I'm uploading an older MySQL file to a newer MySQL server.... I'm pretty sure there's a converter somewhere out there... but I'm gonna give this a shot... I hope my host knows how to do this.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X