Announcement

Collapse
No announcement yet.

upgrade Password BUG !?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade Password BUG !?

    ok, i'm about to go postal.

    trying to upgrade from 2.0 beta and received upgrade files from John. did everything according to instructions - downloaded 2.2.1 and uploaded all the files on top of my 2.0 files. then uploaded John's upgrade files (upgrade6.php thru upgrade9.php) to my admin directory and went directly to upgrade6.php. It told me i had to delete install.php so I did. It then told me i had upgrade1.php and either delete it or run it if I hadn't previously, so I ran it and backed up my database. then went back to upgrade6.php and it asks me to log in at the admin control panel. try logging in using my l/p and it tells me I used the wrong password. try it again. same thing.

    confused, i go to phpmyadmin to my vbulletin user table and see that my password IS correct. so now i'm really confused. try loggin in a few more times to no avail.

    WTF!!!??? I even tried to use the extra getadmin.php script and when i run it it takes me back to the admin control panel with a ****load of error messages:

    Warning: Cannot add header information - headers already sent by (output started at /home/somethin-else/somethin-else-records.com/www/forum/admin/getadmin.php:3) in /home/somethin-else/somethin-else-records.com/www/forum/admin/functions.php on line 1488

    so now I can't upgrade or even run my existing vbulletin since it's shutdown. needless to say my client is THRILLED.

    can someone please shed some light on this bug and how to resolve it? Do I really need to do a clean install and somehow import all of the existing data?

    any help would be greatly appreciated.

    thanks.

  • #2
    that header already sent error most likely occurs when you have white space/line breaks before and after the closing php tags <?php and ?>

    delete the line breaks in the vB php files mentioned in the error message and reupload the files
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      password still not working... grrrr

      there were no extra spaces or line breaks, but i noticed that the getadmin.php script is embedded within an html page (?) why is that? that seems to be the reason why duplicate headers were sent.

      so removed the html tags and didn't get the error messages but even after running getadmin.php i still can't access anything - WRONG PASSWORD.

      again i looked in the user table and used the password there - i also noticed that my username was indeed usergroup '6' (which is what getadmin.php does) but the problem is a password thing. what in the hell is going on?

      why is it that when I enter the correct password it tells me it's wrong? how do i reset the password? getadmin.php doesn't do that.

      when i look into the user table, my password says "newpassword" - but when i type it in to the admin login page it tells me wrong password. this is so frustrating and i have a client riding me to get it fixed considering it was my idea to upgrade (man am i an idiot!).

      i can't be the only one with this problem can I? i must have typed the correct password in 50 times now.

      help me pretty pwease!

      Comment


      • #4
        i think you messed up the upgrade by running upgrade1.php after you ran the upgrade6.php file

        here's what you should do

        1. restore your backup database sql file to an empty database which you should have made a backup of prior to upgrading important to do this first

        2. which 2.0 beta did you upgrade from ?

        beta1 ? beta 2 ? beta 3 ? beta 4 or beta 5 ?

        i assume if John gave you upgrade6.php and up you are upgrading from 2.0 beta 5 ??? if you are then

        3. reupload all 2.2.1 php files to your forum directory except install.php and/or install1.php

        upload all upgrade6.php to upgrade14.php files into /admin directory

        run once only the following and click the bottom next link steps for each upgradeXX.php script

        /admin/upgrade6.php
        /admin/upgrade7.php
        /admin/upgrade8.php
        /admin/upgrade9.php
        /admin/upgrade10.php
        /admin/upgrade11.php
        /admin/upgrade12.php
        /admin/upgrade13.php
        /admin/upgrade14.php

        then remove all upgradexx.php scripts and log in
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          wrong password, wrong password, wrong password...

          did all that again. everything.

          same thing. takes me to the admin login. wrong password.

          i looked in the new admin scripts and through the various requires it seems the culprit is sessions.php lines 49-53

          if (md5($loginpassword)!=$bbuserinfo[password]) {
          eval("standarderror(\"".gettemplate("error_wrongpassword")."\");");
          } else {
          $bbuserid=$bbuserinfo['userid'];
          $bbpassword=md5($loginpassword);

          does this mean the password is supposed to be encrypted? right now it's plain text. if it's supposed to be encrypted, how do I do it and why didn't the upgrade script take care of it?

          i also noticed there's a ton of code that's commented out in sessions.php - some involve password validation. could this be the bug?

          are there files i'm missing that aren't in the 2.2.1 download and files John sent me?

          Comment


          • #6
            If you ran all the upgrade scripts that Eva asked you to, than your passwords would have been encrypted.

            Comment


            • #7
              how can i run all of the upgrade scripts if i can't get past the first one - upgrade6.php???

              am I not supposed to start with upgrade6.php like I was told to?

              i'm running 2.0.5 beta and was given upgrade6.php, upgrade7.php, upgrade8.php and upgrade9.php. I was told to start with upgrade6.php.

              when i access upgrade6.php it asks me to log in. but I CAN'T log in. therefore I can't get any further, right?

              version 2.0.5 beta uses plain text passwords. is upgrade6.php looking for an encrypted password and is that why it keeps telling me i have the wrong password?

              i need to get this fixed ASAP. my client is really pissed off. can someone do the upgrade for me? i'm really desperate and i swear i've done everything as instructed.

              Comment


              • #8
                I am a bit confused about your messages.

                upgrade6.php does not include sessions.php and it wouldn't have told you to remove any upgrade or install scripts.

                I suggest you submit a support ticket in the members area so that you may provide login details.

                Comment


                • #9
                  no upgrade6.php does not include sessions.php - the 2.2.1 package does. I was told to download 2.2.1 and upload all of the files on top of my old files - which I did. John did not mention anything about not uploading install.php. John then directed me to upload the files he sent to the admin directory. did that. So when i went to upgrade6.php (the page John told me to start with) I got a page saying Security Alert! install.php was found in the directory etc. and to delete it before continuing. Did that. Went to upgrade6.php again and now it told me that upgrade1.php was found in the directory and to run it if i hadn't or if i had run it to delete it. So I ran it (as i hadn't run it before). This basically did a mysqldump and output to my browser. So after that was done I went back to upgrade6.php and now i get the admin control panel login page. i cannot get past this page. keeps telling me i have the wrong password.

                  what did i do wrong??? nothing. the fact that upgrade6.php told me to run upgrade1.php and I did what it told me to do? no one told me not to run it. surely this can't be my "messing up".

                  the fact is that the upgrade does not work as-is.

                  i would really appreciate it if someone from vbulletin could look into this as it appears i'm the only one ever upgrading from 2.05 beta upwards.

                  Comment


                  • #10
                    Submit the ticket.

                    Comment


                    • #11
                      wooo hoooo!!!

                      all fixed!

                      turns out I had old versions of the upgrade scripts that were sent to me. Freddie Bingham was kind enough to figure this out and send along the latest ones.

                      they worked like a CHARM!

                      thanks so much for your help and sorry I was so desperate - my client was stressing me out big time!

                      at least there's a happy ending

                      cheers

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X