Announcement

Collapse
No announcement yet.

Board Crashes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nuno
    replied
    If you want to use the CGI binary, do the following:
    Under 'Home Directory', 'Virtual Directory', or
    'Directory', click on the 'Configuration' button,
    and then enter the App Mappings tab.

    Click Add, and in the Executable box, type:
    c:\php\php.exe (assuming that you have unzipped PHP in c:\php\).

    In the Extension box, type the file name extension you want
    associated with PHP scripts. Leave 'Method exclusions'
    blank, and check the Script engine checkbox.
    -----------------------------------------------------------------------------
    -----------------------------------------------------------------------------
    To use the ISAPI module, do the following:

    If you don't want to perform HTTP Authentication using PHP,
    you can (and should) skip this step. Under ISAPI Filters,
    add a new ISAPI filter. Use PHP as the filter name, and
    supply a path to the php4isapi.dll.

    Under 'Home Directory', click on the 'Configuration' button.
    Add a new entry to the Application Mappings. Use the path
    to the php4isapi.dll as the Executable, supply .php as the
    extension, leave Method exclusions blank, and check the
    Script engine checkbox.

    Stop IIS completely (net stop iisadmin)
    Start IIS again (net start w3svc)

    Leave a comment:


  • Morrus
    replied
    Originally posted by nuno
    i believe your are running PHP as CGI binary.
    I don't understand what that means. Is that a setting that I can change somewhere?

    Leave a comment:


  • nuno
    replied
    i believe your are running PHP as CGI binary.

    Leave a comment:


  • Morrus
    replied
    Originally posted by Martin
    what OS and webserver are you using? this seems remarkably like an error I used to get under NT/IIS when trying to run PHP as a module.
    W2K/ISS....

    How did you solve it?

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by nuno
    Steve made a typo
    thats PHP
    I make lots od tpyos!

    Leave a comment:


  • Martin
    replied
    what OS and webserver are you using? this seems remarkably like an error I used to get under NT/IIS when trying to run PHP as a module.

    Leave a comment:


  • nuno
    replied
    there's no uninstall option with php, so my guess is that you can overwrite existing version and follow instructions at install.txt file.

    Leave a comment:


  • Morrus
    replied
    Hmm... there's a PHP 4.1.1 installer at PHP.net. Would running that to install PHP 4.1.1 over the top be a generally good or a bad thing, do you think?

    Leave a comment:


  • nuno
    replied
    Steve made a typo
    thats PHP

    Leave a comment:


  • Morrus
    replied
    Originally posted by smachol
    So I take it that PHP runs as a CGI app on your server then? In my experience HTTP header errors are ususually due to problems in the scripts. What are you trying to do when you get this error? I would suggest reuploading the PHOP file makign sure their are uploaded in ASCII format.

    It's also possible there's some white space at the beginning or end of one or more of these files. Did you modify any PHP files?
    They occur at random times - not caused by trying to do anything specific. They're happening quite a lot, though.

    PHOP? I'm not familiar... is that from the PHP installation? (I don't see it in the vB directory).

    What version of PHP are you using?
    http://bugs.php.net/bug.php?id=4808
    I'd check, but can't connect to my server right now... maybe something to do with the error?

    Leave a comment:


  • nuno
    replied
    What version of PHP are you using?
    http://bugs.php.net/bug.php?id=4808

    Leave a comment:


  • Steve Machol
    replied
    So I take it that PHP runs as a CGI app on your server then? In my experience HTTP header errors are ususually due to problems in the scripts. What are you trying to do when you get this error? I would suggest reuploading the PHOP file makign sure their are uploaded in ASCII format.

    It's also possible there's some white space at the beginning or end of one or more of these files. Did you modify any PHP files?

    Leave a comment:


  • Morrus
    replied
    I started over and reinstalled. Went smoothly.

    However, I'm getting this error frequently (which I was also getting on the previous installation):

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:


    FATAL: erealloc(): Unable to allocate 360448 bytes

    Also I get this on occasion:

    The paging file is too small.
    Board activity is practically zero - I invited 3 or 4 moderator from the old UBB forums over to register and help test; and the old UBB forums seem to be working fine.

    The only thing I can think of is that using the UBB (which I reactivated after the big crash) and vB at the same time is too much strain on the server. vB by itself shouldn't be (I hope) since it reportedly is less resource-intensive than UBB, and my server handled UBB just fine.

    I hate to think what might happen when my users tranfer over from UBB... there are about 9000 of them.

    Then again, I'm just guessing. What would you conclude from those error messages? or is there something wrong somewhere?

    http://www.enworld.org/messageboards/index.php?s=
    Last edited by Morrus; Tue 8 Jan '02, 5:33pm.

    Leave a comment:


  • Morrus
    replied
    Uggh... not only do I have no members now, the registration page throws up the above errors.

    I'm seriously considering switching back to my old UBB boards. They're still installed.

    Leave a comment:


  • Morrus
    replied
    Well, I had a back up in that I didn't delete my old old UBB voard figuring I could always import all over again if I had to. But it appears that I can't do that....

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X