No announcement yet.

Board Crashes

  • Filter
  • Time
  • Show
Clear All
new posts

  • Board Crashes


    My board (2.2.1) is returning an error message:

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

    FATAL: erealloc(): Unable to allocate 360448 bytes

    Any thoughts as to what might be causing this? Thanks.


    Some details you might need:

    Server: W2K

    I haven't edited any files - the software was installed for me by you guys earlier today.
    Last edited by Morrus; Mon 7 Jan '02, 5:58am.
    EN World

  • #2
    Now it's saying:

    The paging file is too small for this operation to complete.
    EN World


    • #3
      What URL is causing this error? I just clicked through your board without getting any errors.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography

      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      • #4
        It seems to have stopped...

        Hopefully it was a one-off - I'll post back here if it happens again.

        Thanks for looking.
        EN World


        • #5
          Well, it stayed up for a few hours before I got this error message:

          There seems to have been a slight problem with the EN World Messageboards database.
          Please try again by pressing the refresh button in your browser.

          An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

          We apologise for any inconvenience.

          Not much help there... but I looked at the source code for that message and saw this:

          <!-- Database error in vBulletin 2.2.1:

          Invalid SQL: SELECT user.*,userfield.* FROM user LEFT JOIN userfield ON userfield.userid=user.userid WHERE user.userid='1'
          mysql error: Can't open file: 'user.MYD'. (errno: 145)

          mysql error number: 1016

          Any thoughts?
          EN World


          • #6
            Sounds like your user table crashed. You need to run repair.php- that should fix the problem. I've had problems with the user, search and thread tables all crashing like that. Repair.php usually does the trick. Good luck!


            • #7
              Unfortunately, I don't have a file called repair.php....

              Does that come with the download? I had the software installed for me, so never actually got the download.
              EN World


              • #8
                Repair.php is in the download of vbulletin in the "extras" folder. If you had it installed and didn't get the download, look to see if the extras folder was installed on your system or perhaps get in touch with the person who did the install. Just upload that and run it (I upload and run mine from the admin folder). That repair.php script should repair your user table with no problem- it's a good idea to keep it handy (I've used mine a LOT since upgrading!)
                Last edited by TigerLily; Mon 7 Jan '02, 1:33pm.


                • #9
                  Oh dear...

                  repair.php produces exactly the same error message!
                  EN World


                  • #10
                    Do you have phpmyadmin installed on your server? You can get to your database and repair it from there if you do.

                    I think I remember having that problem too (sorry, I've fixed the thing so many times now, I forgot!) I think all I did with the user table crashing was to go into phpmyadmin, click on my vbulletin database, click on the "user" table, and then select the "repair database" option. That fixed it in less than 2 minutes.

                    I hope this helps!


                    • #11
                      I don't have phpmyadmin installed. I'll see if I can find it somewhere, though.

                      Uggh.... I've been up for 48 hours now - two nights ago I was trying to keep my old forums alive, working all night; last night I was learning how to get MySQL working and installing it; today I was configuring the boards; now I'm trying to fix something and I'm way out of mydepth.

                      And I still don't have a working forum.
                      EN World


                      • #12
                        i'm sure James will give you a hand on this one
                        all reports are sent to Technical Email, so, James is receiving all error logs
                        You're my Prince of Peace
                        And I will live my life for You


                        • #13
                          I've just made this so much more entertaining.

                          Successfully installed phpmyadmi; but there was no repair option anywhere to be found. In the end I decided to empty the users databse as that was the one causing trouble) and re-import all the member files from UBB.

                          Of course, I didn't think - that natuarally deeted my own account. As the databse was in good shape (although empty), the boards started working again and people started registering etc... I couldn't close the boards as I had no admin access!

                          So... I messed around manually editting databases. Managed to give myself admin access and closed the boards. Deleted all the users who had registered during the time I was messing with the databases, and then started the UBB import process. Only it threw up errors (naturally)....

                          Database error in vBulletin Control Panel 2.2.1:

                          Invalid SQL: INSERT INTO userfield
                          'La Jolla, CA USA',
                          'DnD... duh.',
                          mysql error: Duplicate entry '41' for key 1

                          mysql error number: 1062

                          Date: Monday 07th of January 2002 08:38:08 PM

                          EN World


                          • #14
                            Please tell me you had a backup...


                            • #15
                              Well, I had a back up in that I didn't delete my old old UBB voard figuring I could always import all over again if I had to. But it appears that I can't do that....
                              EN World


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.