Announcement

Collapse
No announcement yet.

Big Problem Help Please!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Big Problem Help Please!

    Ok, I switched my boards from .php3 to .php, this is becuase I wanted it to be compatable with the vbportal. I used the database I back up from my .php3 board with my .php board. (this is so I didnt have to start from scratch again).

    now heres the problem, when I click a link on my board it doesnt work, and I know why I just dont know how to fix it.

    Heres why, I am running the board in .php, but when i click a link for example:
    http://www.hellfireforums.com/forum....php3?forumid=2

    it says .php3 "forumdisplay.php3 instead of forumdisplay.php, this is occuring with everylink. How do I fix this, some one please help. Check ouyt www.hellfireforums.com/forum if you need to see they problem in action.

    Please someone help, thanks!

  • #2
    I think you solve that problem like this;

    Search and replace.

    Do a search for:

    .php3
    and replace;
    .php
    *I think*
    Email: [email protected]
    Site: Under Construction

    Comment


    • #3
      what kaizen said, only oh forgot to mention you should do it the templates search/replace

      Comment


      • #4
        I did that and some of the links where fixed, but if I clikc on like new thread, or psot reply, or even just a post, its still ends up going to .php3 instead of .php. HELP PLEASE!!!

        Comment


        • #5
          Well, you got to replace 'em all. That's all you have to do.
          Can't really help you as previous user already gave you the solution.

          Originally posted by NjEcTiOn
          I did that and some of the links where fixed, but if I clikc on like new thread, or psot reply, or even just a post, its still ends up going to .php3 instead of .php. HELP PLEASE!!!

          Comment


          • #6
            If you haven't altered your templates majorly, try importing the vbulletin.style from the .php zip and overwrite your current templates with it.. That should fix your problem...

            Comment


            • #7
              Im still having problems, can some one please help me do this, please?

              Comment


              • #8
                1) go to Admin CP.
                2) Click on "Search" under "Templates" in the left-side menu
                3) Enter .php3 in search and .php in replace.
                4) Hit submit.

                Another thing: make sure you use the .php vBulletin scripts pack and not a converted .php3 one.

                Comment


                • #9
                  it says this:
                  Doing search for '.php3' and replacing with '.php'.

                  All done!

                  Doesnt work, can someone phisically do this for me

                  Comment


                  • #10
                    is it because im useing the back up of the database from my old .php3 board.

                    Comment


                    • #11
                      I suggest you contact support and open a ticket, to allow one of the official support guys to access your database and/or Admin CP.

                      Don't give strangers (even myself! ) access to your administration

                      Comment


                      • #12
                        Originally posted by bira
                        (even myself! )


                        --

                        I feel sorry for the mod thats got to go through every template
                        Email: [email protected]
                        Site: Under Construction

                        Comment


                        • #13
                          well he contacted me at vb.org so I'm trying to help him now.

                          The search/replace in templates works only for modified templates. It does not alter original templates and he is using all of the original templates, so he just needs to do what The Prohacker said - reload the php version of vbulletin.style. I sent him a small script that will do that. Let's hope this is all it will take

                          Comment


                          • #14
                            We'll see.
                            Email: [email protected]
                            Site: Under Construction

                            Comment


                            • #15
                              yep, that did the trick. Just got a PM from him that everything's fine now

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X