Announcement

Collapse
No announcement yet.

question about valid ext

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • question about valid ext

    I am having trouble with the valid file extension, for the avatar uploading and attach uploading, I am having the same problem, it keep telling me "The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again." even the extension IS .jpg so what's goin on about it?

    I think I've enable ppl uploading files. and it clearly says the valid file extension are "gif jpg png txt zip bmp jpeg"

    Am I just dumb or I forgot something?

  • #2
    What version of vB are you running? Does this thread help?

    http://www.vbulletin.com/forum/showt...ht=valid+image
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      spec: VB 2.1.1
      Apache 1.3.x.x
      unix
      PHP and MySQL : lastest version

      and I noticed that my PHP is safe_mode on. does it mean I can't have my forum members to upload files? any kind of

      I switched to "yes" in the uploading files session, it didn't work.

      Comment


      • #4
        K, I fixed it, it doesn't say "The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again. " any more. I switch to "yes" on the "Allow Image Size Checking Failure?
        " but now, It just won't display. any help?

        Comment


        • #5
          and now, I can upload the file but

          it shows something like this

          Therefore, I'd say I should ask my server part staff about it? cuz it's safe_mode on?

          Comment


          • #6
            BTW there isn't any vB 2.1.1 version.

            What do you mean it just won't display? Do you get a broken image or any errors. Do you have a test account that we can use to test this out? We'll need the URL to your board of course.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I see you posted just as I was writing my message. I also see you're running plesk. There have been many problems reported with servers running plesk. Do a search on these forums and maybe you'll find something that'll help.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                LMAO oh sorry, man. I mean I am on the latest version of VB. guess I shouln'd mess up with the version no. heh

                k, here we go, I think I've post on the forum about the wrong msg.

                and now you can also go to www.importstalk.com ---> the forum and check it out.

                there is a thread from me testing the attach check it out.

                Comment


                • #9
                  Originally posted by smachol
                  I see you posted just as I was writing my message. I also see you're running plesk. There have been many problems reported with servers running plesk. Do a search on these forums and maybe you'll find something that'll help.
                  so you mean it's not because the safe_mode of PHP is "on" ? because of the plesk? what's that?

                  k, I am running a search now.

                  Comment


                  • #10
                    in case, you wanna see the phpinfo,

                    http://www.importstalk.com/testing.php


                    thanks for help!

                    Comment


                    • #11
                      K, now, my server part staff told me this

                      This is how you can upload information to your /httpdocs or other directories via PHP upload. You MUST create a directory inside of your /httpdocs and give it *full* permissions: 777. This means you must CHMOD it to 777.

                      In your PHP scripts you use the function called "move_uploaded_file" to move a file that you previously uploaded to the /tmp directory into the directory that you have just created in the /httpdocs of your account. That was the same directory that you changed its permissions to 777, as described above.

                      You can find more documentation and information on how to use this brand new function here:
                      http://php.net/manual/en/function.mo...oaded-file.php

                      With this function you will be able to move the files from the /tmp directory to a subdirectory inside the /httpdocs directory. You *MUST* then access the file that you have just moved to the subdirectory. You cannot access the file in /tmp at all - you must access to the place where you have moved it to. I hope this was helpful and thank you for your patience and understanding in this matter.

                      so does it mean I have to change the code in the some .php files and use the move_uploaded_file function in there?
                      Last edited by Jordansfd3s; Mon 17 Dec '01, 9:31pm.

                      Comment


                      • #12
                        I solved it. Thanks for help

                        if there's anyone else having the same problem, let me know, I'd like to help.

                        Comment


                        • #13
                          Originally posted by Jordansfd3s
                          I solved it. Thanks for help. [/B]
                          I knew if I just went to bed you'd have everything fixed by the time I got up the next morning. I've got to try that tactic more often!
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by smachol
                            I knew if I just went to bed you'd have everything fixed by the time I got up the next morning. I've got to try that tactic more often!
                            LMAO. all rite. (I didn't meat that, damnit, next time I have prove that you are wrong. )

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X