Announcement

Collapse
No announcement yet.

Broken images after move..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Broken images after move..

    I've moved my forums to http://forums.utassault.net - however all my images are broken. They exist on the server if you go to them directly, but don't show when the page is loaded.

    In my vBulletin options, I have the path set correctly to the new domain, and no trailing slash. My styles all reference the images directly without any URLs of the old site/domain or incorrect paths.

    Im not sure whats going on!

    Any help appreciated.
    HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
    -
    Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

  • #2
    I know people keep saying that file permissions don't matter, but could you humor me and tell me what file permissions you have on the GIFs in the images directory?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      also make sure all images are uploaded in binary mode
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        Originally posted by smachol
        I know people keep saying that file permissions don't matter, but...
        In some cases I might be inclined to agree with you, except for two caveats:
        1) He can access them directly which means they have correct permissions.
        2) Unless someone was in there screwing around, the only files that permissions ever need to be changed on are executable scripts (e.g. .php etc.).

        Comment


        • #5
          Yeah - i'm getting no further with this either...
          HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
          -
          Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

          Comment


          • #6
            Originally posted by tubedogg
            2) Unless someone was in there screwing around, the only files that permissions ever need to be changed on are executable scripts (e.g. .php etc.).
            As a test I just changed the file permissions to 700 for all the GIFs in one of my styles. All the images came up broken. File permissions can definitely make a difference.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              hrm, thanks for your research on that - I'll give it a try.

              What permissions should be set? 644?
              HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
              -
              Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

              Comment


              • #8
                644 should be ok. You just need to make sure the files are world-readable. 600 or 700 breaks them.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  i believe 644 is default for directories created via ftp?
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    Originally posted by eva2000
                    i believe 644 is default for directories created via ftp?
                    I'm not sure about ftp, but I know this is controlled by the umask for each directory.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by smachol
                      As a test I just changed the file permissions to 700 for all the GIFs in one of my styles. All the images came up broken. File permissions can definitely make a difference.
                      Two things about this...First I said unless someone was in there changing things they would be right, which is accurate - when you upload files unless you have changed something on the server they should be world-readable by default. Also, he said he could access them directly which makes me believe that your test was not recreating the situation as he has it.

                      Comment


                      • #12
                        I have no problem with that. The only reason I asked to know what the permissions were was that I helped someone who had this same problem and his were set to 700. Obviously it does happen from time to time. How? I can't really say.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          All sorted now

                          I worked out what it was, 2 problems:

                          1) I'm an idiot
                          2) I forgot about the .htaccess config I used to stop linking of images to external domains...

                          Sorry to have wasted your time guys, many thanks for your help though.
                          HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
                          -
                          Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

                          Comment


                          • #14
                            np

                            Comment


                            • #15
                              Originally posted by Martz
                              1) I'm an idiot
                              Wow - I'm an idiot too - on my Mother's side! Perhaps we're related!
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X