No announcement yet.

Bug - User names with apostrophes & no cookies can't log in.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug - User names with apostrophes & no cookies can't log in.

    This apparent bug has been tried on this forum and it seems to have the same problem as the other forum it was found on.

    If a user registers a username with an apostrophe, for example, I registered the username "Bug's Bugs" here on this vB, then that user cannot log in under certain circumstances.

    If you turn off both cookie options in your control panel, then you cannot log in at this forum.

    Here is something stranger. On the other forum (2.2.1), the user can log in from the front of the site and from the login page, but they cannot log in from the reply to post page. The other forum does allow unregistered posts, this one does not.

    On the other forum, if a user tries to log in to the forum while posting a message, and they have a user name like "Bug's Bug" then the post will show as an unregistered user with the name "Bug\'s Bug". The user will not be told that they are an invalid user, and their password will apparently be accepted, even though they are showed as a guest in the post. The forum I am talking about, where this was discovered, does allow unregistered posts.

    You may try this by registering a name with a space and an apostrophe and turning off both of the cookie options in the user control panel.

    Please let me know if you have any questions about this.

  • #2
    Its a hack you installed that allows user's to register names with 's. I forgot which hack screws this up. I think its a hack that has to do with the users title. i saw this post before hold on.. ill look for it.


    • #3
      Thanks for the response, Goldfinger.

      I do not think this is hack related. I registered the user name "Bug's Bugs" here on this forum ( and I don't have any hacks on my forum.

      I think this is a bug of some sort.


      • #4
        oh.. tubedogg will probably know how to fix this.. just wait a couple minutes till he gets down this far .


        • #5
          I wish I could give you some quick answer...but the truth is I can't even reproduce this at all...


          • #6
            Hi Tubedogg -

            I just did another test here and it appears that I can log in here, at the login page, even with the apostrophed account.

            That makes me think that the bug only happens when you try to log in on the post or reply page (newreply.php). It seems that login option is only available on forums where unregistered users are allowed to post. On this forum, where there is no unregistered posting, I think that you never see the login (Username/Password) on the post or reply page, it always sends you to a login page to log in.

            Can you test this type of username on a forum that allows unregistered users to post - you must try to log in from the page where you are replying "newreply.php".

            Please let me know if you are still unable to reproduce it. I can talk to our developer and get more specifics, but I think you should be able to reproduce it in 2.2.1 as that is what we are using.

            Added Note: even on the site I am working on, users with no cookies and the apostrophe can log in from the login page or the front page of the forum, but they cannot login from the newreply.php page.


            • #7
              You're gonna hate me. I have followed the exact steps you gave - registered a user named Bug's Bugs, turned all cookies off in the User CP, attempted to post, put in my username and password, and it posted. The username was correct as was the user title - Junior Member, not guest. :/

              I tried it repeatedly BTW.


              • #8
                That's expected I suppose!

                I can recreate this problem on the site I work with over and over again and several users are having the problem (which is how I found out about it).

                Is there a test board running the latest version that I can try it on where Unregistered posters are allowed to post? This forum does not appear to allow Unregistered posts, even in the test forum.


                • #9
                  I'll ask John if he can change that for the test forum here for ya.


                  • #10
                    I have had John turn the testing forum here so no reg is required.


                    • #11

                      Thank you Tubedogg. As I should have guessed, I cannot re-create the bug here on this forum.

                      Here is my setup:

                      PHP Version 4.0.6

                      Magic Quotes On

                      MySQL 3.23.35

                      MYISAM Tables

                      I will talk to the developer we work with and see if I can get him to dig deeper into the problem and give me any more specifics.

                      Thanks for all your help Tubedogg and I'll report back if I find out more.


                      • #12
                        Try turning magic_quotes_gpc off. Also if you have magic_quotes_sybase turned on, that should also be turned off (don't ask me why as I don't understand that one ).


                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.