Announcement

Collapse
No announcement yet.

Installing vBulletin 2.2.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing vBulletin 2.2.1

    Server is 215 UNIX Type: L8
    Host type (2): UNIX (standard)
    Host is Speedyweb/Trident/Nexus

    From their email:

    "Hello,

    PHP4 versions is install. The extensions can just be php.

    Database server type: (mysql)
    Database server hostname / IP address: (localhost)
    Database username: (tothecontrary)
    Database password: (xxxxxxxx)
    Database name: (newttc)

    You do have table alter access."

    Installing to /home/tothecontrary/www/vbb/

    Copied all .txt, .php, and .style files in ascii; all others in binary. Used the default set with the .php extensions not the .php3.

    CHMOD permissions on /vbb set to 775
    CHMOD permissions on /vbb/admin set to 775
    CHMOD permissions on all .php files in /vbb/admin set to 775

    Install script started (http://www.tothecontrary.com/vbb/admin/install.php)

    Continue...>

    Confirmed config.php info...>

    "Attempting to attach to database...

    Connection succeeded! The database already exists.

    Click here to continue -->"

    Here is where it gets a bit embarrassing: There is a big red box asking me if I want to EMPTY my db:

    "If you would like to continue and to erase ALL tables from your database, click the button below. This will unconditionally erase the entire contents of your MySQL database, INCLUDING any non-vBulletin data!"

    Because prior to purchasing the Owned license I now have, I was running a bootleg version of vBulletin 2.2 on my web server. I ain't proud of it, but there it is. I DON'T want to empty the db if I don't have to! But I'll do what I must...

    Regarding the bootleg install which installed and worked fine by the way, I renamed the original /vbb folder to /vbb1 and started fresh again with a new folder /vbb.

    Anyway, if I ignore the big red box and "click here to continue"
    I get:

    " Creating table access

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff [but its MY [email protected]" email addy listed], who you can also contact if the problem persists.

    We apologise for any inconvenience."


    And here I am!

    I know enough about FTP and CHMOD and such to get me in trouble and next to nothing about php and less than that about mysql but want to learn the right way.

    What do I have to do next? My face is already red and my spirit chastened...
    Last edited by adaplant; Wed 5 Dec '01, 9:13pm.

  • #2
    One thing to note: You do not need to CHMOD any directories for vBulletin (with the exception of an images/avatars directory, but that's only if you intend to upload avatars via the Admin CP).

    Anyway if you are running 2.2.0 then you should not run install.php but rather upgrade14.php to upgrade to 2.2.1. This will save you having to empty your database.

    Glad to hear you bought it.

    Comment


    • #3
      Thanks. I'm glad I bought it too. I've tried Agora, UBB, EZBoard and vBulletin is definitly the superior forum software to my mind. I was going to buy back in July, but a friend gave me a copy and...

      Ancient history now. [;^)

      I was trying to upgrade to 2.2.1 from 2.2.0 with another bootleg, probably screwed up when I chose to do the fresh install instead of just running upgrade14.php (I don't know why I always wait till late at night when I'm not fresh to the task and apt to make stupid mistakes (like not BACKING UP THE db!)...

      Whoever is responsible for the "http:/www.lol.com/", I owe her.him/them a beer and vBulletin can credit them/him/her (and the superior software I'd enjoyed free for awhile) for my purchase. It got my attention right proper!

      Is it too late to backtrack and do the upgrade route? Even after several abortive attempts to run install.php (and install.php3) on the bootleg (before this current fresh install)?
      Last edited by adaplant; Wed 5 Dec '01, 9:29pm.

      Comment


      • #4
        It shouldn't be, no, if you have not already emptied the database.

        Comment


        • #5
          Upgrade worked flawlessly

          Thanks!

          Found answer to posted question using the "search" function.

          I'll do that FIRST next time.

          Thanks!
          Last edited by adaplant; Fri 7 Dec '01, 2:55pm.

          Comment


          • #6
            np

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X