Announcement

Collapse
No announcement yet.

what are the proper steps in upgrading from 2.2.0 to 2.2.1?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • what are the proper steps in upgrading from 2.2.0 to 2.2.1?

    i need to know the exact steps in upgrading my board w/o losing any data in my 2.2.0 db, so should i

    1. mysqldump my existing 2.2.0 db 1st? then unzip my vb2.2.1 over my old 2.2.0 files.. then run the upgrade14.php

    2. and then do i need to import my db over to the 2.2.1 version? cuz i have extra tables that are in there... i also dont want to lose any of my templates from my 2.2.0 as well. please help me do this w/o losing anything.

  • #2
    First of all make a backup (dump) of your current database. Better safe than sorry.

    Now close your forums from the Admin CP (in the Change Options), and upload all new files from the new version's zip file, except for install.php. Don't forget vbulletin.style!

    Run upgrade14.php, and follow the directions on screen.
    After the script is done with, delete it from your server.

    Go back to your Admin CP, and re-open your forums in the same way you closed it.

    All your extra tables in the database will be kept, don't worry.
    This applies to your custom templates as well.
    The only thing you have left to do is make sure your custom templates are updated with any template changes that were done from 2.2.0 to 2.2.1.

    Again, make sure you backup your MySQL database before doing anything.
    Chen Avinadav
    Better to remain silent and be thought a fool than to speak out and remove all doubt.

    גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

    Comment


    • #3
      You only need No. 1.

      Use mysqldump to backup your db for just in case. If you only do upgrade14.php step, you won't lose your setting and template.

      Don;t forget to close the forum before you upgrade.

      Comment


      • #4
        how do you close the forum? so i guess the only changes i need to make are the changes that are required in the .php files i edited that where in the hacks instructions, everything else will be kept?

        Also firefly you mentioned to unzip vbulletin2.2.1 over my old forum except for install.php? why leave that out? wont i need the new install.php from vbulletin 2.2.1?

        Comment


        • #5
          Go in the vbulletin options to close the board.

          If you are upgrading you wont need the install.php file.
          Email: [email protected]
          Site: Under Construction

          Comment


          • #6
            ahh gotcha =) thanks guys

            Comment


            • #7
              Welcome
              Email: [email protected]
              Site: Under Construction

              Comment


              • #8
                No problem.

                It's never easy to upgrade, that's a sad fact.
                Chen Avinadav
                Better to remain silent and be thought a fool than to speak out and remove all doubt.

                גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X