Announcement

Collapse
No announcement yet.

upgrade problem, templates not showing up, unusual problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade problem, templates not showing up, unusual problems

    I installed 2.2.1 as a test forum and spent quite a bit of time getting all of my hacks in place. Today I finally upgraded my forum from 2.0.3 to 2.2.1.

    I downloaded all of my 2.2.1 files from the test forum and loaded them to my main forum. Silly me didn't realize I had also overwritten my config file. So when I ran the upgrade13.php file, it told me that it appeared I had already upgraded to 2.2.0. I then ran the upgrade14 file, it said it imported a few templates and that was it.

    Then I realized that I had the wrong config file in there and I updated it. I then ran upgrade13 and 14 and it appeared that all went well. It went through the process of encrypting all the passwords and importing the templates.

    However... In my admin panel, none of the new templates are there. Showgroups, register_avatar, or any of the others that came with 2.2.0.

    The passwords are encrypted, and the version number says 2.2.1. Other than that, there are no signs of an upgrade.

    I went back to my test forum because I remembered having seen them on that forum, in fact I even edited the showgroup templates. However, none of the new templates are there any longer either. Except for the two showgroup templates that I edited, but they are showing up at the top under 'custom templates'. It appears that my test forum changed when I ran the upgrade with the earlier config.

    I then wondered if the upgrade files were bad, I had downloaded them on the 18th of november. I had a new download from yesterday so I ran the upgrades again. Upgrade13 tells me I am already upgraded. Upgrade14 tells me it is importing new templates (no matter how many times I run it) but again, there are no new templates in there.

    I'm sorry for being so long-winded, just wanted to give all the details.


    I'm on a dedicated VO#4, dual 933 p3 proc, 1 gig ram, running mysql 3.23.45.

  • #2
    best solution

    1. revert to recent backup of forum
    2. redownload latest vB 2.2.1 zip file from members area
    3. upload php files 2.2.1 to server
    4. check and recheck config.php for right database
    5. close forum
    6. proceed with upgrade
    7. reopen forum
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      I tried to restore my backup, following the instructions to copy to a new database, then use that one. But I dont have enough room left in /var to do this.

      Would it be safe to delete the original database then do this? I do have the backup which I saved via telnet, so it should be intact. This is scary


      I still can't figure out what went wrong though, templates are actually missing from my test forum after what happened. It was just a simple upgrade.

      Comment


      • #4
        I deleted my old database off the server and then I restored my backup.

        I downloaded a brand new 2.2.1 zip and installed it complete and without any hacks.

        I ran the upgrade files to take my database from 2.0.3 to 2.2.1.

        My forum shows that it is 2.2.1 and during the upgrade it encrypted all the passwords. It's the only database I have for my domain, so there's no mistaking that I an connecting to the correct one.


        I checked all my templates and I still don't have any of the new templates from 2.2.0 and 2.2.1.





        My test forum was complete but then the new templates disappeared. So, I just ran the repair.php on my test forum, then I ran the upgrade scripts on it and it installed the new templates. Yay so far

        So I rushed over to my real forum and ran the repair, then I ran the upgrade files but still no luck.

        I compared the output from the two repair scripts.

        On my test forum repair results, under checking and optimizing Table Templates and Checking Table Templatesets, it says the status is "OK".

        On my real forum, the status for those areas says "Table is already up to date"

        Other than that, there are no differences.

        I really want to take advantage of the new features offered by 2.2. I realize I could create the templates myself, but would they even work if the database isn't set up correctly?

        I'm so confused, can anyone help?

        thanks,
        Sue

        Comment


        • #5
          when you reuploaded your 2.2.1 php files did you overwrite config.php ?

          if you want me or one of the vB staff to check it out you can send a support ticket with your vB and server log in details http://vbulletin.com/members/support.php

          mention this thread as well ...

          how big is the size of your vB database btw ?
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            I overwrote the config the first time around. After I restored the database, I used the new config file, but I made sure I had the correct info on it.


            My database is 413 mb.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X