Announcement

Collapse
No announcement yet.

View New Posts Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • View New Posts Error

    Database error in vBulletin 2.2.0:

    Invalid SQL: SELECT searchid FROM search WHERE query='1=1 AND thread.lastpost>=1007020373 AND thread.open<>10'
    mysql error: Can't open file: 'search.MYD'. (errno: 145)

    mysql error number: 1016

    Date: Thursday 29th of November 2001 09:04:45 AM
    Script: http://www.overclockers.at/forum/for...&action=getnew
    Referer: http://www.overclockers.at/forum/index.php?s=
    -> if somebody clicks on the "View New Posts" Link.

    This exists since yesterday, i didn't change anything.

    Suggestions appreciated!

    Regards,

  • #2
    That doesn't look good.

    I am not sure how to fix it but I think your host has to do something with the permissions.
    Email: [email protected]
    Site: Under Construction

    Comment


    • #3
      you have a corrupted search table.. not that bad

      to repair if you have mysql 3.23.x and above is to get the repair.php file from your extra's folder in your vB zip file you downloaded and upload to your site and run it and follow the instructions to repair tables
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        Originally posted by Kaizen
        That doesn't look good.

        I am not sure how to fix it but I think your host has to do something with the permissions.
        error 145 is corruption, error 13 is permissions

        145 = Table was marked as crashed and should be repaired
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          thx

          i notice you didnt put it in the same post - lol

          P.s. You dont have to reply to this lol
          Email: [email protected]
          Site: Under Construction

          Comment


          • #6
            Originally posted by Kaizen
            thx

            i notice you didnt put it in the same post - lol

            P.s. You dont have to reply to this lol
            hmmmmmm
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment


            • #7
              Thank you,

              I'll try it later ...

              Regards,

              Comment


              • #8
                Originally posted by h4p3
                Thank you,

                I'll try it later ...

                Regards,
                no probs... let us know how it goes
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  That was the problem! repair.php worked fine, ...

                  One last question: why does this error occure? What is the fault?

                  Again, thx for the great support!

                  Regards,

                  Comment


                  • #10
                    Originally posted by h4p3
                    That was the problem! repair.php worked fine, ...

                    One last question: why does this error occure? What is the fault?

                    Again, thx for the great support!

                    Regards,
                    might want to read http://www.mysql.com/doc/C/o/Corrupt...AM_tables.html

                    http://www.mysql.com/doc/D/i/Disaster_Prevention.html

                    and

                    http://www.mysql.com/doc/T/a/Table_maintenance.html
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #11
                      *ahh* thx, now is everything clear

                      Comment


                      • #12
                        Originally posted by h4p3
                        *ahh* thx, now is everything clear
                        no probs ... remember to check the links in my signature out too.. it's all useful stuff
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #13
                          Originally posted by eva2000
                          no probs ... remember to check the links in my signature out too.. it's all useful stuff
                          And he gets profit-sharing from MySQL AB for everyone who clicks on those links

                          Comment


                          • #14
                            Originally posted by tubedogg
                            And he gets profit-sharing from MySQL AB for everyone who clicks on those links
                            lol
                            Email: [email protected]
                            Site: Under Construction

                            Comment


                            • #15
                              Eva- thanks for the help!

                              I had the same problem with my search index after upgrading. It seemed to get corrupted after the boards crashed yesterday. I used the repair script, which worked well, but I was still having some strange errors on the boards. New posts weren't being displayed on the forum display pages, and I couldn't delete or edit threads. I emptied the search index table from the admin cp and rebuilt it. That seems to have fixed the problems.

                              Just wanted to post this in case anyone else was getting strange errors concerning the search index AFTER repairing the table!

                              TigerLily

                              Comment

                              Loading...
                              Working...
                              X