Announcement

Collapse
No announcement yet.

uploaded file is not a valid GIF or JPG file. Please ensure that it is an try again?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uploaded file is not a valid GIF or JPG file. Please ensure that it is an try again?

    I just switched servers so I am pretty sure it is the server causing this error. Everybody gets the error if they try to upload a file using the forum attachment feature. My questions is, what exactly do I need to tell my host to "turn on" so that the upload feature will work?

    Any help, is as always appreciated.

    Thanks.

  • #2
    Go to
    yoursite.com/forums/admin/index.php?action=phpinfo
    and look for 'Safe Mode'. Is it marked as 'on'?

    Comment


    • #3
      either that or they're uploading files that exceed the limit you set ? or php is timing out on large files?


      what is the exact errors ?

      what are the size of the attachments ?
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        Originally posted by tubedogg
        Go to
        yoursite.com/forums/admin/index.php?action=phpinfo
        and look for 'Safe Mode'. Is it marked as 'on'?
        Yep. It says safe_mode local and master value is set to on. So what does that mean? Do I need to email the host and tell them I need that turned off?

        Comment


        • #5
          You can, although unless they had no reason for turning it on they will likely tell you no.

          What you *can* do is go to Admin CP > vBulletin Options > Upload Options > and set the following:
          Upload In Safe Mode? > Yes
          Safe Mode Temp Directory > Set this to a directory relative to your forums directory; I would put it in the images subdirectory. So your path would be
          images/tmp
          Then create tmp in the images directory and CHMOD it 777.

          Save the changes on the options page and it should work now.

          Comment


          • #6
            SO that will make it so ALL attachments are in the images/tmp directory? Will they be files? So if I ftp to the server I would see gifs and jpgs?

            What are the drawbacks / gains of running with Safe Mode on/off?

            Comment


            • #7
              Originally posted by Gutspiller
              SO that will make it so ALL attachments are in the images/tmp directory? Will they be files? So if I ftp to the server I would see gifs and jpgs?

              What are the drawbacks / gains of running with Safe Mode on/off?
              nope the files will be only temporary in /images/tmp since they eventually end up in your database itself
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                Originally posted by tubedogg
                You can, although unless they had no reason for turning it on they will likely tell you no.

                What you *can* do is go to Admin CP > vBulletin Options > Upload Options > and set the following:
                Upload In Safe Mode? > Yes
                Safe Mode Temp Directory > Set this to a directory relative to your forums directory; I would put it in the images subdirectory. So your path would be
                images/tmp
                Then create tmp in the images directory and CHMOD it 777.

                Save the changes on the options page and it should work now.
                That didn't seem to work. I went into set it to yes, and changed the directory to images/tmp with no trailing /

                ftped to server went into forumz/images made tmp directory.

                CHMOD to 777, said it completed.

                tried to attach file to post and gives the same error. I tried changing the "Allow Image Size Checking Failure?" to yes and it still gives the same error.

                Any other ideas?

                Comment


                • #9
                  What is the *exact error* you are getting?

                  Comment


                  • #10
                    Originally posted by tubedogg
                    What is the *exact error* you are getting?
                    Well the forumz are having a few troubles right now, so I can't go recreate the error, but it was along the lines of the title of this post. I took out the first part because it was too long to fit in the subject line. But this is pretty close to what it said.

                    Your uploaded file is not a valid GIF or JPG file. Please ensure that it is an try again?

                    Comment


                    • #11
                      We are also having this same exact problem. We are currently working on a hosting site and so we just moved our other site onto the new server, and ever since, we get the same error message.

                      Comment


                      • #12
                        Our server was in "safe mode", we removed that, and still no upload.

                        We put the server into safe mode again, enabled safe mode uploads in vb ctrl panel, and chmod 777 the /tmp directory, still the same error message.


                        Any ideas?? This is a standard Redhat 7.1 distro install, with Plesk.

                        Comment


                        • #13
                          Originally posted by Kyle_TX
                          Any ideas?? This is a standard Redhat 7.1 distro install, with Plesk.
                          Wan't there a problem associated with Plesk?

                          http://www.vbulletin.com/forum/showt...ighlight=Plesk

                          http://www.vbulletin.com/forum/showt...ighlight=Plesk

                          http://www.vbulletin.com/forum/showt...ighlight=Plesk

                          I think the threads above provided answers. Same problem with avatars and attachments
                          There are only 10 types of people in the world: Those who understand binary, and those who don't

                          Comment


                          • #14
                            Yes and there is a fix by removing some getimagesize code. I run on a plesk host and it works fine.
                            JTMON

                            Comment


                            • #15
                              In this thread, the problem is solved one way. Also in here is the link to another fix.

                              http://www.vbulletin.com/forum/showt...ght=attachment
                              JTMON

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X