Announcement

Collapse
No announcement yet.

Why can't I upload MP3s (or other large files) to my board?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why can't I upload MP3s (or other large files) to my board?

    Q: Why can't I upload large files (such as MP3s) to my board, even though I've changed the maximum file size in the Admin CP?

    A: There are two system variables that must be changed to allow large file-size uploads. They are in the files php.ini (PHP's configuration file) and my.cnf (MySQL's configuration file). If you are on a shared or virtual host, chances are you will not be able to edit either of these files and will need to contact your host for assistance.

    The variables that need to be changed are:
    php.ini: upload_max_filesize
    my.cnf: max_allowed_packet

    In addition, your server may limit the size of HTTP POST operations. This varies from server to server so consult your web server's documentation on how to adjust this.
    Last edited by tubedogg; Mon 1st Jul '02, 1:51pm.

  • #2
    Is there not a limit on the file that will fit in the BLOB in the attachment table? Or is that affected by the value in my.cnf?

    Marc.
    Marc Hanlon
    Rushland.net

    Comment


    • #3
      POST_MAX_SIZE

      You also need to increase POST_MAX_SIZE in php.ini

      Mike.
      Mike Doherty
      UniPro Ltd

      Comment


      • #4
        Hmmmm... I've sorted out php.ini, but in the MySQL config file (my.ini in my case) there's no reference to max_allowed_packet. Any ideas?

        Comment


        • #5
          Originally posted by Lastaii
          ...but in the MySQL config file (my.ini in my case) there's no reference to max_allowed_packet. Any ideas?
          Just add one.

          set-variable = max_allowed_packet=xM

          ...with 'x' being the packet size in Mbs.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Yep, that did the trick, thanks

            Note: I also had to increase the max_execution_time value in php.ini, as PHP was timing out with large attachments (>20Meg). All is good now tho

            Comment


            • #7
              I believe there is a hack on vBulletin.org that makes attachments stored as files, instead of being in the MySQL database.

              HTH


              vBulletin.org, not vBulletin.com...
              Last edited by MUG; Tue 25th Jun '02, 5:39am.

              Comment


              • #8
                note max_allowed_packet is limited to 16MB in size for mysql 3.23.x versions
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  Ah...That would explain why I couldnt upload a test 20M file...

                  Note to self: Don't trust your users ability to calculate filesize

                  I'll try that hack MUG suggested, if that doesnt work, then they'll just thave to FTP the data like they used to

                  Comment


                  • #10
                    Re: Why can't I upload MP3s (or other large files) to my board?

                    [i]
                    A: There are two system variables that must be changed to allow large file-size uploads...
                    1) How large is "large?"


                    2) I have 75-100k image limits, and I'm trying to preserve upward compatability with 3.0 when it comes out.

                    I understand vB3 will store images externally. Would it be better for compatibility's sake to store images internally or externally with the hack?

                    Thanks & regards,

                    Matt

                    Comment


                    • #11
                      I came over the fix on another place and thought I would share; look for php.conf on red hat systems (mine is /etc/httpd/conf.d/php.conf), you`ll see the setting you`re after.
                      Last edited by Haakon; Fri 25th Jun '04, 5:07am.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X