Announcement

Collapse
No announcement yet.

Couldn't retrive Password

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Couldn't retrive Password

    Dear sir,
    after I had upgraded my forum from 2.0.3 to 2.2.1, I got a big problem.
    when users couldn't remember their passwork, anc click on forget password, they enter their e-mail.
    but
    They recieve an e-mail with link to reset their password.
    When they click on this link
    the main page of error is shouwn with now detailes.
    and the recieve an empty e-mail again.
    So
    what can they do
    help me please
    http://www.wvvw.net

  • #2
    take a read here http://vbulletin.com/forum/showthrea...threadid=32661

    have you edited those templates prior to upgrade to 2.2.1 ?
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      I did that
      but I didn't enable the verification for the e-mail in the admin cp
      http://www.wvvw.net

      Comment


      • #4
        glad

        glad someone else is having this problem.....mine is the same way

        Comment


        • #5
          Hi
          I solved the problem, all what do you have to do is to add two template for retriveing password
          So, to solve the problem go to admincp
          click on "add templates
          and the first one is:
          emailsubject_resetpw
          and it should include:
          Your new password for $bbtitle
          then creat another one
          email_resetpw
          and it should incude;
          Hello,

          As you requested, your password has now been reset. Your new details are as follows:

          Username: $userinfo[username]
          Password: $newpassword

          To change your password, please visit this page:
          $bburl/member.php?action=editpassword

          Regards,
          $bbtitle Team
          then creat the last one:
          error_resetpw
          and it should inculde:

          the password has been sent to you<a href="member.php?s=$session[sessionhash]&action=editpassword">click here to edit your password</a>.
          and everything should be ok
          http://www.wvvw.net

          Comment


          • #6
            The Problem ist that second eMail.
            I don't receive it. I receive just the first one, with the passw. reset.

            Comment


            • #7
              Originally posted by wvvwnet
              Hi
              I solved the problem, all what do you have to do is to add two template for retriveing password
              So, to solve the problem go to admincp
              click on "add templates
              and the first one is:
              emailsubject_resetpw
              and it should include:
              Your new password for $bbtitle
              then creat another one
              email_resetpw
              and it should incude;
              Hello,

              As you requested, your password has now been reset. Your new details are as follows:

              Username: $userinfo[username]
              Password: $newpassword

              To change your password, please visit this page:
              $bburl/member.php?action=editpassword

              Regards,
              $bbtitle Team
              then creat the last one:
              error_resetpw
              and it should inculde:

              the password has been sent to you<a href="member.php?s=$session[sessionhash]&action=editpassword">click here to edit your password</a>.
              and everything should be ok
              I am going to "bump" this thread, because you just saved me, countless time messing around figuring out a email validation template. I cannot thank you enough for this information.

              Comment


              • #8
                Some Changes

                there are two changes that I made to the templates as described above, and they are as follows:


                email_resetpw

                Hello,

                As you requested, your password has now been reset. Your new details are as follows:

                Username: $userinfo[username]
                Password: $newpassword

                Regards,
                $bbtitle Team
                Mostly, because the link, will not allow the person to edit anything, due in part, he has not officially been to your site, to actually activate the new password, in order to edit it. I could see maybe adding in a link to your forums, rather than the edit link though.

                The next change, is geared towards boards, such as mine, that do not allow unregistered users, or guests to post. The link provided before may work for those boards who do not have those similar settings, however, I chose to leave it out, due in part, the user should actually be forced to check his E-mail for his/her new password.

                error_resetpw

                Your <b>New</b> password has been sent to the E-Mail you provided at Registration. Until you have received your new password, depending on the Administrative settings at $bbtitle, you may not be able to post, nor change your settings until you have verified the New Password Validation link in your E-Mail.
                Last edited by ToraTora!; Thu 29th Nov '01, 1:27am.

                Comment


                • #9
                  So what should be the correct fix for all of this?

                  Something has obviously changed once upgraded to 2.2.1. None of the email templates were edited prior to the upgrade, and I have receiving a fair number emails per week now such as this one:
                  I can not get into the site. My password xxxxxxxxx will not be accepted. I am
                  frustrated . I've tried it twice yet I still cannot get in. Please help!
                  I show that this person, a new registrant, is fully registered, but has been unable to log into the forums. I receive about 5 of these emails per week since the upgrade.

                  Something isn't right here and if I'm getting 5 emails like this per week, it makes me wonder how many people have experienced the same problem, said "screw this" and left not bothering to contact me.

                  I'm not sure if this has something to do with the new MD5 encrypted passwords, or not, but I'm not too happy with the new password system and I'm not sure the benefits of going to MD5 encrypted password protection can be seen here. Just my two cents.
                  Rob

                  Comment


                  • #10
                    Have they clicked on the reset password link that was sent to them in the email? Have you added the above changes, plus the template changes that tubedogg posted Here! in your templates?

                    I guess that the old templates (which you have) were not overwrote in the upgrade, due in part the were not added, and the template changes shown in the link provided, and the above posts in this thread, will cure the problems that users are having changing their passwords.

                    just make sure they change their passwords if they are having problems logging in with their old passwords before the upgrade, and all should be ok.

                    Comment


                    • #11
                      Originally posted by ToraTora!
                      Have they clicked on the reset password link that was sent to them in the email? Have you added the above changes, plus the template changes that tubedogg posted Here! in your templates?

                      I guess that the old templates (which you have) were not overwrote in the upgrade, due in part the were not added, and the template changes shown in the link provided, and the above posts in this thread, will cure the problems that users are having changing their passwords.

                      just make sure they change their passwords if they are having problems logging in with their old passwords before the upgrade, and all should be ok.
                      I am running the latest version - 2.2.1 and the templates didn't need upgrading because they are word for word, exactly the same as those in Kevin's post. I double checked them before posting here.
                      Rob

                      Comment


                      • #12
                        Does this help?
                        http://vbulletin.com/forum/showthrea...threadid=34286

                        Comment

                        Loading...
                        Working...
                        X